Plugin compatibility

I just purchased the wpmu template plugin and was under the impression that WPMU has been merged with regular version of Wordpress. So I setup a subdomain to try the plugin and when I tried to activate, it failed saying that it is only compatible with WPMU.
It doesn't look like the plugin was what I was hoping for which was to create a wordpress theme anyone could install that included certain content and categories on a standard wordpress installation.
Please advise if this is possible or should I just request a refund?

Thanks,
Leonard