Plugin Didn't Work for Multi-Domains

I just got this error trying to install the Multi-Domain plugin

The plugin does not have a valid header.

And it didn't install. What's going on here?