Plugin doesn't create the two tables (queue_table and log_table)

Hello, I'm using a wordpress 4.3.1 multisite with PHP 5.4.16 and MySQL 5.6, we also use multi DB plugin, but for some reason when we create a new blog, it doesn't create the two tables (queue_table and log_table). So it can't send emails.

Does anyone have the same problem?

  • Michael Bissett

    Hey @Jackeline, Michael here!

    ...but for some reason when we create a new blog, it doesn't create the two tables (queue_table and log_table). So it can't send emails.

    You mean to say that the tables in question aren't created for the newly created blog?

    If so, are there any errors coming up in your server's error log about those two tables not being created when a new site is created on the network?

    Please note in the midst of all this, that Multi-DB is a decommissioned plugin, as noted on the project page:

    https://premium.wpmudev.org/project/multi-db/

    Kind Regards,
    Michael

  • Michael Bissett

    Hey @Jackeline, my apologies for the delay here!

    In looking at this further, it seems like something that we'll want to have the developer of Subscribe By Email comment on, I've asked him to have a look at this here.

    In the meantime, could you please send in the following via our secure contact form, just in case he needs the information:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include cPanel access details (login address, username & password) - so he can access phpMyAdmin if need be (for database access)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks a bunch! :slight_smile:

    Kind Regards,
    Michael

    • Jackeline

      Hi!!!
      Yes I recently updated, and the tables are there finally but I have another error:

      Error Unknown column 'campaign_hash' in 'where clause' de la base de datos de WordPress para la consulta SELECT * FROM wordpress_f.wp_842_subscriptions_log_table WHERE campaign_hash = '4442e3e5cb7ba3cc910d201f91e1c379' realizada por edit_post, wp_update_post, wp_insert_post, wp_transition_post_status, do_action('transition_post_status'), call_user_func_array, Incsub_Subscribe_By_Email->process_instant_subscriptions, Incsub_Subscribe_By_Email->enqueue_emails, incsub_sbe_insert_campaign, m_wpdb->query

      It's a multisite.

      Do you know something about this new error? it was in the error_log when I published a new post.

  • Michael Bissett

    Hey @Jackeline, thanks for your patience here, hope you had a great weekend! :slight_smile:

    It sounds like the "campaign_hash" column is missing from the database for some reason, but that's something that we can address manually.

    However, I'm not seeing that the details I requested previously were sent in, could you please send those in, so that this can be dealt with? :slight_smile:

    Please advise,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.