Plugin doesn't work on debian squeeze and ispconfig 3

Hi,

I'm (try to) using Snapshot.
My configuration :
Debian squeeze with ispconfig 3
WP 3.4.2 (standolone mode - no network)

Impossible to use the plugin without change my server config. And i don't want to change this. I work hard to build it (:

This is the error message :

Warning: require_once() [function.require-once]:
open_basedir restriction in effect.
File(/usr/share/php/PEAR/Exception.php) is not within the allowed path(s):
(/var/www/clients/client6/web8/web:disappointed:var/www/clients/client***/web8/tmp:disappointed:var/www/****.com/web:disappointed:srv/www/mablogacademy.com/web:disappointed:usr/share/php5:disappointed:tmp:disappointed:usr/share/phpmyadmin:disappointed:etc/phpmyadmin:disappointed:var/lib/phpmyadmin) in /var/www/clients/client6/web8/web/wp-content/plugins/snapshot/lib/destinations/dropbox/includes/PEAR_Includes/HTTP/Request2/Exception.php on line 47

Warning:
require_once(/usr/share/php/PEAR/Exception.php) [function.require-once]: failed to open stream: Operation not permitted in /var/www/clients/client***/web***/web/wp-content/plugins/snapshot/lib/destinations/dropbox/includes/PEAR_Includes/HTTP/Request2/Exception.php on line 47

Fatal error:
require_once() [function.require]: Failed opening required 'PEAR/Exception.php' (include_path='.:disappointed:usr/share/php:disappointed:usr/share/pear:disappointed:var/www/clients/client***/web***/web/wp-content/plugins/snapshot/lib/destinations/dropbox/includes/PEAR_Includes') in /var/www/clients/client6/web8/web/wp-content/plugins/snapshot/lib/destinations/dropbox/includes/PEAR_Includes/HTTP/Request2/Exception.php on line 47

I investigated and found the soluce.
I must change several parameters on my server. As i say, i don't to do it for one plugin.

So, i try another (and free) backup solution (backwpup) and this solution working.

So ?
If you want to see the problem by yourself before refund, i can give a access to my site.

Regards,
Stef' (from France, sorry for my english).

  • stef418
    • WPMU DEV Initiate

    An other detail :

    Impossible to connect to Amazon S3.
    I gave my credential, but the plugin can't connect ton my account.
    I try with BackWPup, it's work.

    Really, the issue coming from my server.
    But i don't want to modify it for one plugin...
    Hope you can understand this point.

    Thank's.

    Stef'.

  • Paul
    • The Green Incsub

    @stef418, for the Dropbox issue there are fundamental differences with the implementation between our Snapshot plugin and BackWPup. The Snapshot plugin uses a library provided by Dropbox. This library assumes PEAR is installed in the server. The other plugin uses direct curl calls. Both will work. But in your case Snapshot looses out because it relies on PEAR which you don't have accessible from your configuration.

    In Snapshot the Dropbox library is loaded from snapshot/libs/destinations/dropbox You can safely remove that folder and the errors will go away. However you will not be able to use Dropbox for Snapshot.

    As for the AWS the other plugin does use a different library for interactive with AWS. I've seen one other user (including Tim on this thread) who reported issues connecting to AWS. I've tried from half a dozen servers I have access to and was able to connect each time. Would love to get access to your server to investigate this.

    Or maybe not. Since you have a backup solution and mentioned a refund you might be just provided information and ready to move away from WPMU DEV. That is of course your choice. Besides the Snapthot plugin we have plenty of other advanced plugins you have access to as part of your membership.

  • stef418
    • WPMU DEV Initiate

    Hi Paul,

    If you want to test, i can give you an acces on my site to check this issue.
    I ask the refund cause actually, this plugin doesn't work with my server.

    But i like wpmudev.
    I use several plugin on different sites, they work.
    Snapshot is the first wo don't to working well.

    And, if i can help you the fix this issue, no problem (:

  • Paul
    • The Green Incsub

    @stef418, Received. I was able to login and verify this is something with AWS. I tried my own access keys. When I click the 'Select Bucket' the server returns null. This should be a JSON array of the buckets. I can't go much further than this on your site. I need to see if I can find a similar site where I can get to the backend. For now I'm going to mark this as a bug so it will get looked into and not forgotten.

    Thanks for your report and help in brining this to my attention.

    Best,

    Paul

  • Paul
    • The Green Incsub

    @stef418, I would never break someone else's server (famous last words). For now sit tight on this. Again I need to see about getting a server that is somewhat vanilla that I research this. I'll be back to you later in the week hopefully for some more debug help.

  • Paul
    • The Green Incsub

    @stef418, On second thought I'm curious if you have the same issues under your sandbox environment? Sitting here working and watching the World Series I just tried on 4 other client sites I have access to. All are very different hosting system from dedicated to shared. On all 4 I was able to connect to AWS and list the bucket as well as test the connection.

  • Paul
    • The Green Incsub

    @stef418, Afraid phpinfo is not going to help. I need to see why the AJAX call is returning null. For this I need to access and add debug information to the AWS files that are part of Snapshot.

    Is it possible to setup an FTP account with the home directory as the snapshot plugin folder? That would help.

  • Paul
    • The Green Incsub

    @stef418, Thanks for the access. Was able to dig through the AWS library code we are using for Snapsot. Found out one of the CURL options it uses is not allowed since you are using 'open_basedir' which locks things pretty tight.

    After some searching I found a patch and applied. Now I can select buckets and/or test connection. That is as far as I've taken it.

  • stef418
    • WPMU DEV Initiate

    Hi Paul,

    Juste a last thing.
    I can connect to AWS, but, Snapshot gave me this error :

    ERROR: Warning: errno:512 S3::putBucket(bck418, public-read, ): [BucketAlreadyOwnedByYou] Your previous request to create the named bucket succeeded and you already own it. /var/www/clients/client6/web8/web/wp-content/plugins/snapshot/lib/destinations/aws/amazon-s3-php-class/S3.php on line 222
    2012-10-29 15:16:46: ERROR: Error: Could not change bucket to :bck418

    I tried with several different parameters, always the same issue.
    Do i made a mistake ?

  • stef418
    • WPMU DEV Initiate

    Ok (:
    Your account still there.

    And, a new problem during the snapshot :

    ERROR: zip archive add failed [Array ( [type] => 8 [message] => A session had already been started - ignoring session_start() [file] => /var/www/clients/client6/web8/web/wp-content/plugins/snapshot/snapshot.php [line] => 2156 ) ]

  • Paul
    • The Green Incsub

    @stef418, Have uploaded a beta version to your site and tried running the latest snapshot configuration. Now when it hits the files section I see the error

    ERROR: zip archive add failed [-2] [Unable to open temporary file 'pclzip-508ec7610c1a1.tmp' in binary write mode] memory_limit: 128M: memory peak usage: 94M

    This is generally an out of memory error. This is using the PclZIP library which comes with WordPress.

    Looking into the Amazon error/warning.

  • Paul
    • The Green Incsub

    @stef418, Wanted to catch you up on the changes to Snapshot since this morning. I've worked today to convert the code to use a different AWS library. Seems to have cleared up the issue on your site. I've also added two new options on the AWS form.

    Region: This is to select the region for the file.

    Storage: Defaults to Standard. Can also be Reduced Redundancy

  • stef418
    • WPMU DEV Initiate

    Hi Paul,

    Thank's for your hard word, you rock's (:

    But... hum...
    Always this error

    ERROR: zip archive add failed [-2] [Unable to open temporary file 'pclzip-508fd9abc43ea.tmp' in binary write mode] memory_limit: 128M: memory peak usage: 103.75M

    Do i have to modify something ?

  • Paul
    • The Green Incsub

    @stef418, This is going to be one of two things. I'm seeing this one some other members threads. Answer this

    By default the PclZIP configuration as implemented by WordPress defined a temporary file path as your site root. If your site root is not writeable then when PclZIP goes to create the temp file it will fail. My question to you is your site root directory read only? If it is can I ask that you set a define in your wp-config.php to override the default page.

    define( 'PCLZIP_TEMPORARY_DIR', '<SOME PATH>' );

    The '<SOME PATH>' needs to be writable and the path MUST end in with a slash / I generally suggest creating a temp directory
    <site root>/wp-content/uploads/tmp/

    I'm also working today to use an alternate Zip library.

  • stef418
    • WPMU DEV Initiate

    Hi Paul,

    Ok, i removed the line.

    I found an other problem.
    I'm using a premium theme (sintia by vamtam.com)
    When i activate Snapshot, i can't saved my theme options.
    Work's well when i disable snaphot.

    I had a a message "Allowed memory".
    So, i put "define('WP_MEMORY_LIMIT','64M');" in my wp-config.php, not better.
    I will send a message to the theme developper.

  • Paul
    • The Green Incsub

    stef418,

    It very well could be that your combined plugins and theme are using close to your 64M limit. It could be that before Snapshot you memory usage is just under that limit and operational. Installing snapshot and performing a backup of course uses more memory, no way around that. But snapshot fails because it needs more memory to manage adding files into the zip archive.

    Again, I'm working on convering all the existing code in Snapshot that uses the PcLZip library, which does used more memory than it needs. To using a bette zip library. Should have this ready in a few hours to test. Hopefully all this can live under the 64M limit.

  • Paul
    • The Green Incsub

    @stef418, Thanks fro your patience. and thanks again for providing access to your system to prove out my plugin coding.

    As of this evening my time I've uploaded hopefully the final beta for Snapshop 2.0.4. I've run a few manual snapshots using the 'test' item in the list. Things seem to work. Meaning no failures that I can see on the screen or logs. Part of the new Beta supports the built-in PHP ZipArchive as an alternate to the WordPress PclZip library. New also in this beta is a head above the progress bars when creating a snapshot to show the current memory limit, memory usage and memory peak usage.

  • stef418
    • WPMU DEV Initiate

    You are a Ninja !

    It's work, now, i can say : "This is a great plugin" ((:

    Many thank's for all you hard work Paul. Respect.
    A beautifull support you gave me there.

    I will xait for the official update, an if everything work, close this thread.

  • Paul
    • The Green Incsub

    @Timothy, @stef418,

    Thank. Kudos. If I were King these issues would have NOT have been in the release!

    But anyway, @stef418 thanks again for the invaluable access to your site during my testing. As a developer having access to many external sites and feedback from users is what makes our plugins better for all users. I'll be sending points your way. Did you know if you get 1000 points you get free lifetime membership?

    I still would like to get back to your original issue related to the Dropbox errors. But I want to get this release out the door soon.

  • Paul
    • The Green Incsub

    @stef418, Hope you are well. Wanted to finally circle back to your original post on Snapshot and the Dropbox errors you reported in your initial post on this thread.

    I remember when I was logging into your site I didn't see these errors. So assumed they are in your logs. Wanted to see if this is still occurring after upgrading to the latest version of Snapshot released today.

    Can you post a fresh log update here so I can see what errors are still being hit?

    As always thanks for your help.

    Paul

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.