Plugin has made my site slower

This is the direct link to Appointments+. or as a sub menu of "contact us"

The login information for access is:
username - [moderated]
password - [moderated]

  • Sajid

    Hello Vince,
    Hope you are doing good today :slight_smile:

    First of all, never ever post login credentials on public forum like this. I have removed the credentials but it is still recommended to change passwords or better delete this account.

    Whenever we need to take a look at your site, support staff will request you enable support staff access.

    Coming back to your issue. Yes, I could see this issue on your site, but it is loading fine on my own test site.

    Could you please try increasing the memory limit and maximum execution time by one of methods mentioned in this blog post and then check if it makes any difference.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

  • Sajid

    Hello Vince :slight_smile:

    I am assuming you heard back from your hosting and posted the error message from error log. It says, the page is going to 404, but when I try to access this page on browser, it is throwing gateway time out. That means, the server disconnected before the request complete.

    That mostly caused due to limited server resources. Did you tried increasing the memory limit as I suggested in my previous reply ?

    If no then, please try to increase those limits as described in this blog post and then check if it makes any difference.

    Before making the changes, note down the existing memory limit and execution time in WPMU DEV -> Support -> System Info -> PHP, so you could compare those later to make sure the changes are actually take effect.

    If these does not make any changes, then you would to contact your host and ask them adjust memory limits accordingly.

    Also, I see you have not enabled pretty permalinks. Please try to enable permalinks from Dashboard -> Settings -> Permalinks (recommended settings i post name). This usually does not required but its good to configure it out too.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

  • Sajid

    Hello Vince :slight_smile:

    It is still gateway time out for me. Please send in FTP (account should have access to sys logs so I can see why it is failing) and WordPress admin details directly so I could take a closer look.

    You can send the requested details via our secure contact form in following format.

    Subject: "Attn: Sajid Javed”
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference

    Best Regards,
    Sajid - WPMU DEV Support

  • Sajid

    Hello Vince,
    Hope you are doing good today :slight_smile:

    I have fixed this issue by removing the WordPress memory limit you set in wp-config.php file to 256M (I have commented it out and left it in wp-config.php file - see below screenshot). Even though you PHP memory limit is set to 768M that is handsome amount of memory for all scripts to run properly on your site.

    I am really sorry for delay on this ticket. I been on vacation for a couple of days and it seems this ticket got missed assigning other staff member.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support