Plugin Not Holding Custom Meta Titles and Descriptions

Hi there;

We had WPMU Dev SEO running fine and then upgraded and lost all our custom meta titles and descriptions across our multisite installation. I believe this was a known bug that you fixed a couple of weeks ago. Since then the customization worked briefly but has now broken again. We write in custom descriptions and they disappear within hours. I tried customizing one of our user's pages, and when I logged back in this morning the Title and Description sections had reverted to blank (screenshot attached).

We have version running; the changes for do not mention this issue in the details. Will upgrading fix the issue, or should we be looking for a different plugin entirely to handle this?

Thank you for your help.

  • Philip John
    • DEV MAN’s Apprentice


    Please update to the latest version regardless – always best to start there as a good footing.

    What other plugins do you have installed? What’s clear is that *something* is deleting the value you enter into those fields. It could be SEO or it could be something else.

    If you can, disable everything else and see if the issue persists.



  • amieq
    • WPMU DEV Initiate

    Hi Phil;

    I’ve tried the update and I have altered one of the meta page titles and descriptions. It is showing up right now but I will check again in a few hours, since it usually ‘disappears’ after a few hours.

    The other plugins I am running across our network are:

    Amikelive Google Adsense Widget

    Google Analytics

    New Blog Templates

    RSS Includes Pages

    WPMU DEV Update Notifications

    I am hesitant to turn them off since we have around 100 people using the service. Do any of those stand out as possible suspects in particular?

    I appreciate your help!

  • carterharkins
    • WPMU DEV Initiate

    I’m having the same issue, and I also have the New Blog Templates plugin installed, which I wondered about as a potential conflict, but I’m not using that theme on the site in question, and did not use this site as the basis of the template associated with that plugin, so not sure, just mentioning it here because of the similarity…

    This morning I noticed that a post’s meta description had reverted to the site wide default. I noticed that there was a new update for the plugin, so I updated the WPMU Dev SEO plugin to today’s newest release. I again changed the meta description for a particular post, saved, refreshed the page and verified that the meta description was updated. It was. I came back, refreshed the page again about an hour later, viewed source, and it had reverted back to the site wide defaults.

    I will deactivate all other plugins except the SEO plugin, and see if I can troubleshoot a conflict next, then report back here when I have results to report.


  • carterharkins
    • WPMU DEV Initiate

    Well, that didn’t take long… All plugins deactivated, made the meta description change, saved, refreshed, viewed source, verified the change was there and correct. Then, I wondered how long it would hold, so I just refreshed the source view, and watched it instantly revert to the default site-wide settings. * five seconds later upon refresh*

    Hope that helps. I’m turning plugins back on for now.

  • Vladislav
    • Dead Eye Dev


    I’m sorry for the delay about this, and thank you for the awesome troubleshooting you did and all the details you included. The code that saves the meta states is more or less completely changed in the latest version (v1.0.9.7, just released). Can you please try to upgrade and see if it helps?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.