plugin not working

just bought it installed...but when you choose a time to book it freezes
just the loading icon and the no form dropdown to continue

http://www.jessiepavelka.com/make-an-appointment/

how to fix?

  • Hakan
    • The Incredible Smush

    Hi,

    This is about Appointments+ plugin, is that right?

    I see several jQuery errors on the page. In fact we have an answer in FAQ section exactly for that:

    I have just installed Appointments+ and nothing happens as I click a free time slot on the Make an Appointment page. What can be the problem?
    If you have created the appointment page manually, check if you have added app_shortcode which is always required to complete an appointment. If this is not the case, you most likely have a javascript error on the page. This may be coming from a faulty theme or plugin. To confirm the javascript error, open the page using Google Chrome or Firefox and then press Ctrl+Shift+j. In the opening window if you see any warnings or errors, then switch to the default theme to locate the issue. If errors disappear, then you need to check and correct your theme files. If they don't disappear, then deactivate all your plugins and re-activate them one by one, starting from Appointments+ and check each time as you activate a plugin.

    Cheers,
    Hakan

  • jessiepavelka
    • New Recruit

    hi,

    so having problems
    http://jessiepavelka.com/index.php/make-an-appointment
    dosent work right when you select time just loading icon and no drop down form

    https://jessiepavelka.com/index.php/make-an-appointment
    Works BUT only when I'm signed in as admin
    so if a client clicks time..it asks for the admin user and password?

    my plug ins are
    Category Posts
    Contact Form 7
    Facebook Like
    Facebook Social Widgets
    Flickr Gallery
    Really Simple CAPTCHA
    SI CAPTCHA Anti-Spam
    WP Tweet Button

    let me know ASAP

  • Hakan
    • The Incredible Smush

    Asking a password shows that it is a CPanel setting. Please check your cPanel settings.

    Also your .htaccess file does not seem not correct to me now. Did you make some changes there compared to last week? All your links have index.php now, e.g.:

    <a href="http://jessiepavelka.com/index.php/a-message-i-want-to-share-with-you/"

    Please try with the default WP .htaccess file.

  • Hakan
    • The Incredible Smush

    Did you already check this:

    Please check your cPanel settings.

    By the way, I have difficulty to understand why some links of your website are http and some are https. Sorry but I have to ask this: Do you have experience on https websites?

    Please open your home page using Google Chrome and press Ctrl+Shift+j. You will see warning and error messages there, some coming from improper safe content (https), some coming from javascript. Please fix them first.

  • jessiepavelka
    • New Recruit

    hi,
    not experience on https in wordpress

    the site has a SSL cert and the appointment+ only works with https
    so the link to the page has https
    with http://jessiepavelka.com/?page_id=404 the pulgin freezes when time is selected

    the only improper safe content items are a twitter code and flicker plugin
    which are on all pages...i took them off..still doesnt work..I put them back
    the client wants them their

    I think the problem may be that this wordpress template Theme
    Canvas By WooThemes Version 3.1.

    has 2 login prompts to get to the wp-admin

    if you cant fix it... my only other thought is to install a new separate Wordpress
    in a folder like jessiepavelka.com/WP2 and just make one page and put the appointment+ plugin their and other links will lead back to the first (main)Wordpress site

    don't know if thats possible 2 wordpress on same server or if that will cause other issues
    but what do you think we should do

  • Hakan
    • The Incredible Smush

    I think the problem may be that this wordpress template Theme
    Canvas By WooThemes Version 3.1.

    I don't think so, but checking this is quite easy: just temporarily switch to the default theme (2012).

    but what do you think we should do

    First of all remove all traces of https in your settings, including your cPanel and .htaccess.

    Once you make it work on the http version, then you can consider changing the website to https, but I think you will need professional help in that stage.

    Cheers,
    Hakan

  • Tom Eagles
    • Syntax Hero

    Hiya, just going through some of the older threads here.

    As it's been a little while since we last heard from you I thought I'd check in to see how you're going?

    If you're still looking for some further assistance with this thread then please feel free to reopen the thread or of course for any new and related issues you are most welcome to open a new thread.

    Cheers!
    Tom

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.