Plugin not working as expected

I get the feeling that there is something small I have overlooked in configuring this plugin although I have gone through the setup several times and read whatever I can on installation. It is so close to working perfectly I hope you can help.

None of the problem situations below generate any error messages on the screen. I have not found any error logs, but I don’t really know where they might be hiding.

1. Can you advise a quick way to disable display of the page title on the integration page please? I want a title on the page so we can see it in the admin end, but it is not required to display to users.

2. Login attempts with vaild credentials always got back to a Client Area login page with a message that “You must login to access this page…”. In spite of this display the login is effective. Click on the “Portal Home” menu item and the Account and Statistics widgets display confirming login success. URL and test login creds available.

3. Whether logged in or not clicking on the Order function and selecting a Hosting package, then selecting the “I will update my nameservers…” option, entering a domain name and clicking OK, returns you to the Shopping Cart menu. This operation works fine in the WHMCS native interface.

4. Whether logged in or not clicking on the Order function and selecting anything other than the default product cat returns to the Portal Home. This operation works fine in the WHMCS native interface.

5. The Account Widget is missing the “Search” heading above the search field.

6. This is outside the scope of the integration plugin but I would like to set up a page template specifically for the integration page that has a slimmer RH sidebar so that the WHMCS content fits nicely in the main content section. I can’t make a general sidebar mod for the site – I just need it to make the integration page work nicely. Can you point me in the right direction for a quick way to do this please?

  • tonyz
    • Flash Drive

    Upgraded WP to 3.4. This has made a difference.

    Item 2: Logins now work OK.

    Item 3: Hosting nameserver selections now work OK.

    Item 4: Product/Services categories sometimes list Addon and Domain options which is incorrect. Selecting anything other than the default value returns display to the Portal Home.

    New Items

    7. In the Knowledgebase display “Portal Home” and “Knowledgebase” on the breadcrumb line do not have encoded links. They link directly to the WHMCS folder.

    8. The Account widget includes a “Quick Navigation” header or title line.

  • aecnu
    • WP Unicorn

    Greetings tonyz,

    Welcome to WPMU Dev!

    Thank you for these valid questions and for updating your WordPress to version 3.4 which as you have proven to yourself was causing several issues.

    Now before proceeding I would like to find out if you have updated the WHMCS WP Integration plugin which was just released a few hours ago?

    Please advise and let me know what issues if any persist.

    Cheers, Joe

  • tonyz
    • Flash Drive

    Hi Joe,

    I have not updated the plug-in.

    Using the plugin Update function in WP says I have the latest version.

    If I download the update and Install it from within WP will it overwrite the existing install and work OK?

    If not what is the correct procedure please?

    Tony

  • tonyz
    • Flash Drive

    Just to recap on these unresolved issues;

    1. Change Product Selection Group does not list different product group. Returns to client area for any selection

    2. Portal Home and Knowledgebase items in KB breadcrumb trail incorrectly link to the WHMC interface. Other links in breadcrumbs are OK.

    3. No "Search" title in the Account Widget between the Login button and teh search textbox. See attached image

    If we can get these things resolved I will be content to wrestle with formatting niceties without assistance.

    I have found how to prevent display of WP Page Title on the integration page.

  • aecnu
    • WP Unicorn

    Greetings tonyz,

    Thank you for the update and the screen shot, it is greatly appreciated.

    I have no answer for these remaining issues or why they are an issue at all.

    Therefore I will see if I can get the lead developer in here with his invaluable insight into this plugin for his advice/advise for us.

    Though this may take a bit longer then a normal ticket, I will try to get him in here asap.

    Cheers, Joe

  • Arnold
    • El Macho WP

    OK here are some

    1. Go into the templates/orderforms/verticalsteps/products.tpl and around line 11 change the GET to a POST.

    <form method="post" action="{$smarty.server.PHP_SELF}">

    Don’t know why they are inconsistant there.

    3. Just add whatever title you want to the Widget for the Search. We don’t fill it in because it may need to say something like Search WHMCS as opposed to Search WordPress.

    2. Is a bit more difficult. The plugin works by redirecting any relative urls to our own page which then displays it in WordPress. Those breadcrumb fields are not relative in the original. We normally leave fully qualified urls alone because they are things like download file or links of to twitter or other third party things.

    It’s another inconsistance in WHMCS programming because breadcrumbs elsewhere are relative. I don’t have a quick fix for that one because it’s embedded in their code rather than the template and I’ll have to get back to you

  • tonyz
    • Flash Drive

    Thanks Arnold.

    1. Fixed.

    2. Will raise with WHMCS – can’t see that’s this will get much traction tho. Still – not you problem.

    3. I guessed as much but search as I might, I cannot find which file or where I might hack the code that writes the widget. Please toss me a morsel that we set me on the scent.

    It is important that the plugin works flawlessly as I’m sure you’ll agree. Suddenly switching out to the WHMCS interface will completely through half of my clients and shake their confidence in me.

    Clearly there are inconsistencies in WHMCS and you have alluded to others as well. Of course this makes it difficult for you traing to intelligently wrap it in WP. Perhaps it is time for a high level delegation to Matt.

    Thanks for your help in any case.

  • tonyz
    • Flash Drive

    To recap…

    1. Fixed product group selection in vertcal menu with hack to WHMCS template file.

    2. New release of your plugin has addressed the breadcrumb trail links. Thank you.

    3. To add (or modify) title over Search field you said

    “Just add whatever title you want to the Widget for the Search. We don’t fill it in because it may need to say something like Search WHMCS as opposed to Search WordPress.”

    Do I understand correctly from this “Sorry, it would be in the knowledgebase.php. But that’s ioncube encypted so you can’t change it. “

    that it is not possible to title the search form?

    When WHMC presents the search form it has a it has a title “Search”. That would do me. Alternatively we could leave the whole knowledgebase search function out of the widget.

    Where can I edit the contents of the widget?

  • Arnold
    • El Macho WP

    On the search title. You are making it over complicated. Every widget has a title field whether it’s our widget or a standard WordPress widgets. Just go to Appearance | widgets, open it and type whatever title you want. Has nothing to do with the plugin.

  • tonyz
    • Flash Drive

    Please be assured my aim is to uncomplicate.

    Your reply does not match what I see. Yes many widgets do have configurable titles. Easy.

    However the widget I am using here is your WHMCS Account Widget and it does not have a title field. Even if it did, under normal logic of widget titling that title would not affect the line of text I am focused on – which is the title of a component form – the knowledgebase search.

    See attached images which illustrate what I see..

    The other two widgets in my sidebar display when a user is logged in and this function works well.

    If I am still missing something or should expect to see something different please advise.

  • Arnold
    • El Macho WP

    You’re right and I apoligize. I should have looked closer.

    You can fix it in the templates/portal/footer.tpl file. Around line 49 is a line

    <p class="header">{$LANG.knowledgebasesearch}</p>

    Move it down below the form line on the next line. It should be included in the form like it was for the login form just above that area.

    And I’ll add the titles to the widgets. Doesn’t help much here because the accounts area is two forms when not logged in and one text are when logged in so the title wouldn’t get inserted in the right place anyway.

  • tonyz
    • Flash Drive

    Thanks. Exactly the info required.

    Display looks good now. A few other tweaks required, and I will document those for the guidance of others later in the forum.

    Now the encoded urls…

    The [page] part of the encoded link does not work when the link is included in another shortcode that is part of my theme.

    I have tried substituting &#91 and &#93 for the [ and ] characters. Shortcode works with this, but the links are not acceptable to your integration plugin.

    I have taken this up with the theme developer. There is some ‘smart parsing’ going on that has outsmarted our encoded links.

    I would have thought it was courting danger to use characters in an encoded link that are typically used in the foundation application to facilitate code replacement blocks (ie in WP – shortcodes). Including links in shortcodes is common enough. WP installations invariably end up with way too many cooks in the kitchen :wink:

    This is just FYI. NFA required on this linking business at this point.

    Thanks very much for your help over the past few days.

    Tony

  • tonyz
    • Flash Drive

    Good thought. and the link now gets past any shenanigans in the theme widget. We now get as far as the Integration plugin but with errors.

    WHMCS Integration: A valid URL was not provided

    My link is;

    http://www.clickonIT.com.au/whmcs/cart.php?a=add&pid=17

    It works as a straight link to WHMCS

    Encoded it looks like;

    ?whmcsportal[page]=whmcs%3A%2F%2Fwww.clickonIT.com.au%2Fwhmcs%2Fcart.php%3Fa%3Dadd%26amp%3Bpid%3D17

    Changed to;

    ?whmcsportal%5Bpage%5D=whmcs%3A%2F%2Fwww.clickonIT.com.au%2Fwhmcs%2Fcart.php%3Fa%3Dadd%26amp%3Bpid%3D17

    Looks accurate in HTML on the page. When clicked I get the message

    WHMCS Integration: A valid URL was not provided

    I have also tried this using

    /whmcs/cart.php?a=add&pid=17

    which also works as a straight link, but when encoded also gives the error message.

    See it in action;

    http://clickonit.com.au/automated-website-backup

    See the “Signup” button in the “Business” product box.

    The encoding system has changed. When I first started using this plugin it was one string of code, now it has a different format. Is that a clue?

  • tonyz
    • Flash Drive

    OK. That’s a good tip.

    However the stuff after [page]= is what the encoder is giving us. Please have a look at it carefully. It decodes as

    whmcs://www.clickonIT.com.au/whmcs/cart.php?a=add&pid=17

    That can’t be right surely?

    I confess I saw that and crafted another encoded possibility…

    whmcsportal%5Bpage%5D=http%3A%2F%2Fwww.clickonIT.com.au%2Fwhmcs%2Fcart.php%3Fa%3Dadd%26amp%3Bpid%3D17

    A bit rude as I have no idea what the encoded link does inside.

    When clicked that reloads the page the automated website backup page (the one where the link is).

  • Arnold
    • El Macho WP

    You’ve still got mixed www. and non-www. urls in your setup. This will work

    http://clickonit.com.au/client-area/?whmcsportal%5Bpage%5D=whmcs%3A%2F%2Fclickonit.com.au%2Fwhmcs%2Fcart.php%3Fa%3Dadd%26pid%3D17

    This won’t.

    http://clickonit.com.au/client-area/?whmcsportal%5Bpage%5D=whmcs%3A%2F%2Fwww.clickonit.com.au%2Fwhmcs%2Fcart.php%3Fa%3Dadd%26pid%3D17

    The three setup urls, 2 for WHMCS on Settings General, and one in the integration plugin must all match. What’s happening now is sometimes WHMcs throws in a www. and sometimes it doesn’t. This may also be due to redirection in your .htaccess trying to force things to www. and not doing it consistently.

    On forming the urls.note that the “http” is replaced by “whmcs” this is because some hosting companies like Hostgator filter urls out of querystrings as a security precaution. This avoids the filter and the plugin translates it back when it uses it.

  • tonyz
    • Flash Drive

    Thanks. Got it.

    It also seems that the link needs to include the integration page to work, correct?

    As you referred above, this works;

    http://clickonit.com.au/client-area/?whmcsportal%5Bpage%5D=whmcs%3A%2F%2Fclickonit.com.au%2Fwhmcs%2Fcart.php%3Fa%3Dadd%26pid%3D17

    This, which is just the encoded link pasted raw into a link on a content page…. does not;

    http://clickonit.com.au/automated-website-backup/?whmcsportal%5Bpage%5D=whmcs%3A%2F%2Fclickonit.com.au%2Fwhmcs%2Fcart.php%3Fa%3Dadd%26pid%3D17

    So the encoded link provided by the Integration still needs a bit of swaddling to get it to fire.Or maybe it is the .htaccess? I’ll have a look Tuesday. Oops it is Tuesday!

    Anyway we have a working process. Thanks for you patience and explanations.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.