Plugin Performance is really bad

Hi there,

I just wrote a post in the members forum and though, it is actually a support request as well.
Please read it and let me know what you think:
https://premium.wpmudev.org/forums/topic/plugin-performance-seems-to-be-really-bad?replies=1#post-1094004

Thank you!

Warm regards,
Sebastian

  • Rupok

    Hi Sebastian, hope you had a wonderful day.

    So sorry to hear that our plugins could not make you the happiest. Regarding Ultimate Branding, it's weird. You are right, this should not take this much resources so I tried to regenerate this on my test site. But surprisingly Ultimate Branding was simply out of equation. Please check the attached screenshot for reference.

    So I'm wondering why this is taking this much resource on your site. And it leads me to the idea that it's not a generic issue, rather this is your site specific issue.

    First thing, I studied a bit about P3 Plugin Profiler and got some interesting information:

    # There are some impressive swings in load time between each scan (if you do multiple scans one after another). Furthermore, the data collected presents some curious anomalies.
    # P3 actually “changes its environment” in order to measure it, so getting precisely accurate results is impossible.
    # If you take a few different measurements at different times, doing so will provide such skewed results that it seems impossible to know what “reality” is.

    Actually it's pretty tough to work on this and describe why Ultimate Branding is showing high usage in report of your site.

    Second thing, as P3 is not a standard benchmark, can you try some alternatives too? If all showing same data pointing to Ultimate Branding, we will definitely investigate further and try to pull it low.

    This article provides some alternative of P3 Plugin Performance Profiler: http://wordpress.alternativelist.com/plugin/p3-plugin-performance-profiler-alternative-and-similar-wordpress-plugins-7986.html

    Regarding Membership 2 Pro, actually it's a very big plugin, and we are continuously trying to add new features requested by our users. As this is a vast plugin, and users need new features and bug fixes urgently on a continuous basis, sometimes some bug occurs and we try our level best to kill those as soon as possible. But can you please explain what type of bad performance you are facing with Membership 2 Pro? We will try our level best to solve this for you.

    I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Sebastian

    Hi Rupok,
    thanks for your quick reply. I appreciate it!
    And it is actually day- time here in Bali. I am going to start my work again after a lunch break. :slight_smile:

    I am going to do more testing and I will also find out which are the plugin really causing trouble. It may be that Ultimate Branding only causes trouble in conjunction with another plugin or it may even turn out that the information provided by P3 isn't accurate.
    So before I go on in assuming about bad performance of some WPMUDEV plugins I am going to test by deactivate and reactivating all the plugins I am using to see where the performance problems may be rooted.

    And in regards of the Members II Pro plugin, I am just still waiting for the WPMUDEV support to report that the bugs I have reported about a free of cost membership are fixed. I can't use the plugin at the moment simply because it gives people confusing feedback when they register. Just have a look at my previous report request in case you don't recall what I reported.

    Thank you!

    Warm regards,
    Sebastian

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.