Plugin update Issue: Could not find update in transient, or filesystem permissions

Previously I used to get a 'source not found message' when trying to update plugins. I was asked to manually update the WMUdev plugin. Which I did.

Now I keep getting the message: Could not find update in transient, or filesystem permissions

Permissions on the uploads and plugins folder are set to 0755

Please advise as I cannot keep deativating, deleting and uploading important plugins manually all of the time.

Note: There is no issue with installing new plugins via the dashboard, only in updating them.

  • Rupok
    • Support Ninja

    Hi Erum,

    This is really weird. I tried to regenerate the issue on my test site, but I could not. So I think this is your site specific issue.

    To find out the reason for which this error is shown, I checked plugin code and found this:

    // $upgrader->upgrade() returned false.
    // Possibly because WordPress did not find an update for the project.

    So somehow, your WordPress instance can't find update for those plugins. Now as you said you can install plugins fine, that means there is no blockage between your server and our servers. That also means, there is something on your site which is blocking the update process.

    Can you please make sure you don't have any plugin which may block update process? Just to make sure no other plugin is causing this, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Can you please also make sure you don't have any of these three defines in your "wp-config.php" file?

    define( 'WP_AUTO_UPDATE_CORE', false );
    add_filter( 'auto_update_plugin', '__return_false' );
    add_filter( 'auto_update_theme', '__return_false' );

    Please let us know the results. If the issue is still there after checking all these, would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Erum
    • Syntax Hero

    This is a live site so I cannot deactivate plugins at whim. However, earlier I had tried that when it was not live and still got the issue. Also previously I think it used to update plugins from what I can remember.

    I will just grant access. Please check in 2 min.

  • Rupok
    • Support Ninja

    Hi Erum,

    Thanks for granting Support Access. I logged in and could see the issue in action. After doing some tests, I got a feeling that there might be some issue with your temporary directory on your server. Can you please check this article? https://churchthemes.com/wordpress-update-failed-to-write-temporary-file/
    It described nicely about the fact. Can you please try the workaround mentioned there?

    I believe, it will help. If this doesn't resolve your issue, please let us know. We will be glad to investigate further.

    Have a nice day. Cheers!
    Rupok

  • Rupok
    • Support Ninja

    Hi Erum,

    Thanks a lot for this info. It gives us valuable insight regarding the fact. This time, I installed an older version of our plugin through the native WordPress dashboard, then went to "WPMU DEV > Plugins" section and tried to update the plugin. Surprisingly the plugin updated without any issue. I've created a screenshot showing that: http://take.ms/vLbuK

    But it's showing the same error for the Snapshot plugin. So I believe, this is not generic for all our plugins on your site, rather there is something wrong (maybe wrong group ownership or something, I need to check) for this Snapshot plugin directory.

    You confirmed that folder permission is right. Still, can I please have a look? I'm sorry this thread is going this long, but trust me, we want to fix this problem for good. Can you please send me message with SSH access credentials through our secure contact form here: https://premium.wpmudev.org/contact/ ?

    Subject: "Attn: Rupok"
    - SSH root Username
    - SSH root Password
    - SSH Host IP
    - Link back to this thread for reference
    - Any other relevant URLs

    Select "I have a different question" for your topic. This and the subject line ensure that it gets assigned to me.

    I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Erum
    • Syntax Hero

    Actually the problem was with all the other plugins from you guys.

    What did was I went and renamed the plugin directories.

    For example I renamed Marketpress to Marketpress-b

    It updated and automatically renamed the directory back to the correct one.

    I only left the snapshot one so you guys can troubleshoot and see what the problem is. I also asked my hosting guys to test so had to leave one plugin as-is so the issue could be narrowed down.

    Have you downgraded the WPMUdev dashboard version??

  • Rupok
    • Support Ninja

    Hi Erum,

    No, I didn't change anything for WPMU DEV Dashboard plugin on your site. I just installed an older version of "Subscribe by Email" plugin on your site from "Network Dashboard > Plugins > Add New > Upload Plugin" section. Then went to "WPMU DEV Dashboard > Plugins" section, and then created this screencast: http://take.ms/vLbuK

    As you can see in the screencast, the plugin "Subscribe by Email" updated without any problem. I didn't have to rename any folder or anything. Do you want me to test with any other specific plugin? I can do that and screencast the whole thing if you want.

    I believe, from now on, if you install any plugin through our DEV Dashboard plugin, this issue won't come again. If it does, please let us know. We will surely investigate further and will try to resolve this for good.

    Have a nice day. Cheers!
    Rupok

  • Kasia Swiderska
    • Support nomad

    Hello Georganix,

    I'm really sorry that you have this issue. However it would be better if you'd create own thread if that issue is still present on your site so we could investigate it on your site - and this way we won't annoy author of the original thread with messages that are not related to their problem.
    Please also remember to enable support access to your site.
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.