Plugins: Advanced Custom Fields and Custom Post Type UI

I am taking a course on Wordpress from Tree House.
I added 2 Plugins: Advanced Custom Fields and Custom Post Type UI
My custom post type is named Art.
I set-up custom post fields.
I added new art and uploaded an image.
I "add new" to Pages and named the title: My Art. On the "Template" drop down menu I selected "Art Page"
I can see the post on the website, but the image is not coming up.
Can someone help me figure out why I can't see the image?

  • Nithin

    Hi Susan,

    Hope you are doing good today. :slight_smile:

    I'm afraid, it's pretty tough to troubleshoot this without checking your website, could you please share the link to the page, or if possible enable support access, so that we could give a closer look regarding this.

    Maybe you don't have post thumbnail assigned in your template, could you please add the following code in your template, and see whether it works?

    <?php
    if ( has_post_thumbnail() ) {
    	the_post_thumbnail();
    }
    ?>

    If the above didn't work, please enable support access, so that we could have a clear idea about the issue.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Ash

    Hello Susan

    Do you have only two lines of code in art.php file? If so, then rest of the code is missing.

    I added new art and uploaded an image.

    Where did you add the image? In featured image option or inside post content or in the custom field that you added?

    If it is in featured image, then Nithin's code should work. If inside post content, then it should automatically.

    If you added in custom field, then you will need custom code. Please try the following code in that case:

    <img src="<?php echo get_field( "CUSTOM FIELD NAME" ); ?>">

    Replace CUSTOM FIELD NAME with the correct filed name that you added. You need to put the code in html block, not in php block.

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

  • Susan

    Ash,

    I don't really understand the difference between feature image option and post content. I was following along with Treehouse's Lesson on: Custom Post Types and Fields in WordPress. I downloaded a few files from that lesson and added them to Vantage Child Theme.
    I added a custom post type called: Art.
    I set-up custom post fields which included a section to add an image.
    Then I clicked on Art and added "new art"
    Then I clicked on the icon "Add Image" I uploaded the image.
    When I click on All Art, I can see the image, but when I go to the website: dedicatedlandscapers.com the image is not appearing.
    In my Vantage Child Theme, I have the following files.
    art.php (This file has more than two lines. I just posted a file lines from it when I replied to Nithin)
    content-art.php
    footer.php
    functions.php
    header.php
    image.php
    screenshot.jpg
    single-art.php
    style.css
    I don't see an html block as you mentioned.

  • Ash

    Hello Susan

    I have checked your site but it seems your child theme is not correctly setup. I don't see any style and anything to load but the plain text.

    Would you please enable the parent theme and check? Also please enable support access so that we can check.

    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I will be happy to take a look :slight_smile:

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.