Plugins can't be updated

I'm building a new site on a multisite network that I did not set up. None of the WPMUDev plugins will update. I also had to manually update WP to 4.8 (from 3.9) because it was not recognizing that there was an update needed. I also manually updated the WPMU Dashboard plugin.
Updates Fail from the WP plugin menu, and from the WPMU Dashboard, they refresh without doing anything.

  • Predrag Dubajic
    • Support

    Hi Matt,

    Can you tell me if the issue is specific only to this site or your having the same issue on others as well?

    Do you have a site where updates are working but is hosted on the same server as the non working one?

    Also, could you check with your host if there's anything in server log that could tell us what's going on?

    Best regards,
    Predrag

  • Matt
    • Site Builder, Child of Zeus

    It's a multisite network, but it's the only one on this server, so I don't know if it's a problem with other sites on this server.

    The only plugins that are even showing available updates are the WPMUDev plugins (Cloner, Domain Mapper, Snapshot) and I think some of the other plugins should have updates available.

    In my browser console it says "Enabling maintenance.... The Plugin is at the latest version... Disabling maintenance.

    The server error log shows this error several times, but I'm not sure if it's related:

    ModSecurity: Warning. Match of "rx ^POST$" against "REQUEST_METHOD" required. [file "/etc/apache2/mod_security/custom/wpbrute.conf"] [line "14"] [hostname "www.thefriends.org"] [uri "/gs-bin/php-stable/wp-login.php"] [unique_id "WVUNdUDPiAoAACNxZNUAAAA0"]

  • Predrag Dubajic
    • Support

    Hi Matt,

    It looks like your site is having issues communicating with external sources.

    Updates are showing as available only for WPMU DEV plugins but if you check your other plugin versions and compare them to latest versions on wp.org you will see that most of your plugins are outdated but your site is not getting in touch with wp.org to check this.

    Here are couple examples, your Contact Form 7 plugin is at 3.8.1 while latest version is 4.8, WP Super Cache on your site is 1.4 and on wp.org it's 1.4.9 and so on.

    Same issue preventing your site from checking wp.org for plugin version is most likely blocking WPMU DEV plugins from being updated as well but I'm not sure what the cause is and you should check with your hosting provider about that.

    Let us know how it goes.

    Best regards,
    Predrag

  • Matt
    • Site Builder, Child of Zeus

    Predrag,
    Thanks for your response. I think you're correct that my site is unable to communicate with external sources. Unfortunately for me I've been communicating with my host about this issue for about a week now and they also have no solution and no knowledge about what may be causing this issue.

    I can't find any forum posts here or through Google searches that seem to be dealing with this particular issue so I am unable to solve it.

    At this point I think maybe it's a plugin that is causing the issue, but I can't delete old plugins until the new site is finished and launched.

  • Dimitris
    • Support Star

    Hey there Matt,

    hope you're doing good today and don't mind chiming in here! :slight_smile:

    The best practise here would be to create a staging environment, meaning an exact copy of this multisite installation in another location/folder in the same server.
    You could then perform a basic conflict test as described here
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2
    and visualised here
    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif
    without having the concerns of the live site. :wink:

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.