Plugins that say "Compatibility WordPress 3.5"

If the plugin says, Compatibility WordPress 3.5, and doesn't mention the others, like this:

Compatibility
WordPress 3.5, Multisite 3.5, BuddyPress 1.6.2

Does this mean it is ONLY for single wp sites, and will not work on multisites?

Thanks,
Tom