Plugins to work together

Hi everyone at WPMUDEV,
I've had this question for a while, is there a way for you to make plug-ins work together? Some plug-ins have such great features that you want them to be used on the site you're building. But they may not work with other necessary plug-ins that you already have to use. How can you get plug-ins to work harmoniously?
Thanks for your excellent advice :slight_smile:
Luke
* needs to go in the plugins forum. Oops!

  • Predrag Dubajic

    Hey Luke,

    Hope you're doing well today :slight_smile:

    Well, with all the plugins available out there it's simply impossible to have them all working together.
    There could be number of different issues, usually related to code so it would require code changes of one of them to work with other.

    Some simple example would be if two plugins have same function name but don't check if such function already exists and that causes errors, this could be solved by simply renaming one function but I'm afraid that most of the issues are not that easily fixed :slight_frown:

    Basically getting in touch with the plugin developer would be best move in conflict issues.

    If you have issues with some specific plugins we could have a look and see if there's a quick fix for it :slight_smile:

    Best regards,
    Predrag

  • Luke

    Thanks Predrag,
    I figured as much, but I would also like to get my head into PHP so I can try and diagnose/fix this myself.
    I ask because we have a site that has been very funky since day 1 and I have a strong conviction it is due to conflicting plugins.
    I have contacted the theme authors and their fix is conflicting plugins as well.
    If you would like to give it a look, I can provide you login.

    Thanks for your speedy reply!
    Luke

  • Milan

    Hello Luke ,

    Hope you are well today and won't mind me chiming here. :slight_smile:

    If theme developers are already looking onto it, then its better that we wait for their update here. After they update you, if you think that there is still need for further investigation, please feel free to grant us staff access and let us know. Also please include theme developer's response so we can understand in which context they tested and concluded !! :slight_smile:

    Kind Regards,
    Milan

  • Luke

    Hi Milan, glad to have you chiming in :slight_smile:

    I have already contacted the theme authors and their reply was:

    "This problem because hosting or you using another plugin strange ? Try to move site to new hosting, we think it will be fine."

    I feel like that might have a little to do with it, but I am really uncertain because everyone has been telling me different things. Wish I could just test the site and see exactly what is going on.

    I am happy to let you have a look.

    Thanks for reading Milan and Predrag,
    Luke

  • Predrag Dubajic

    Hi Luke,

    Actually it could be related to hosting as well, if you're on shared hosting with lots of limitations your site can be behaving badly.

    However before switching your host it would be a good idea checking for plugin conflicts.
    First thing to do is disabling them one by one and see which one is causing issues.
    For example if everthing is working after disabling Plugin_X you can enable it again and then try disabling other ones, again one by one.
    If your site gets back to normal again after disabling Plugin_Y it means Plugin_X and Plugin_Y are not playing nicely together.

    Can you try performing this test and let us know if you manage to figure out which plugins are conflicting so we can see if there's anything we can do to help out with this.

    Best regards,
    Predrag

  • Luke

    Hi Predrag & Milan, hope all is well :slight_smile:

    I wanted to keep you up on my testing and discussion with the plugins/site loading issue:

    Hello Bearsthemes,
    In regards to the speed problem, we have found that one plugins slow our site/your theme down
    Bears Core
    We took the steps you recommended

    Upgrade our hosting to the fastest business plan (unshared),
    Deactivate all plugins and reactivate single plugins until we find the problem,
    Deactivate all 3rd party plugins.

    Unfortunately with all plugins deactivated and only Bears Core activated the site is slow. Here are the results from our tests:

    Bears Core Only: 15sec
    Visual Composer & Bears Core: 11 - 20 sec
    Visual Composer, Ultimate Addons, Bears Core: 6 - 10sec
    Visual Composer, Ultimate Addons, Bears Core, Charitable, TB Donations: 10 - 15 sec.
    All plugins to complete our site (Visual Composer, Ultimate Addons, Bears Core, Charitable, TB Donations, Event Manager, Custom Post Type UI, Contact Form 7, Newsletter, Slider Revolution *no 3rd party plugins): 10 - 11sec.
    All theme required plugins (no third party plugins): 17 - 20 sec
    All theme required plugins with Bears Core deactivated (no third party plugins): 4 - 6 sec

    From our testing we found that the Bears Core plugin played the main role in slowing down our page load times.

    Thank you for looking into your theme's Bears Core plugin speed issue as the site is going out at the end of the week & we would like it to load in 4-6 seconds.

    Hopefully the theme author will have a fix for this. Otherwise, do you have any recommendations?

    Thanks for reading!
    -Luke

  • Dimitris

    Hey there Luke,

    I trust you're good today and don't mind chiming in! :slight_smile:

    We're very glad that you shared this info with us. It really seems that this is narrowed down now, so feedback from theme author is what will be most important here.
    I guess that if these issues can't/won't be handled, the best move should be to test another theme. This may require some extend work (again!) but it will most probably be the best for you!

    Feel free to share with us whatever feedback you get from theme author. :slight_smile:

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.