Plugins updates but it says failed to update

I have hundreds of websites on WPMU and the update WPMU Dashboard fails every single time and folder permissions are correct.
I have tried inside wpmu and in wp-adminthe only way it updates (slower) is via traditional plugin page in wp its been an issue for a while and i hoped you would have fixed by now, all other plugins do not experience this issue.

THe plugins are updated but can't check if this is really happening on thousand websites.

  • Adam Czajczyk

    Hello Mark,

    I hope you're well today and thank you for your question!

    I'm not sure if I understand it right, so let's please first make sure that we're on the same side here.

    I understand that these updates work fine

    - via "Plugins -> All plugins" page -> update plugin
    - via "Dashboard -> Updates" page

    and these don't work

    - via "WPMU DEV -> Plugins" page
    - via "The Hub" (your WPMU DEV account)

    Is that correct?
    Also, you mentioned that "plugin updates but it says failed to update". Is that that when you update via "WPMU DEV -> Plugins" page it reports an error but the plugin turns out to be updated anyway?

    Please confirm or correct me if I'm missing anything here. Also, let me know please if this was always this way for you or if it started to happen just recently.

    Please advise!
    Best regards,
    Adam

  • Mark

    Hello Adam

    Answer # 1: correct.

    Answer # 2: correct . message: update failed. check folder permissions.

    This has been ongoing for a few months, probably since your team had too much fun redesigning WP-Admin WPMU Dashboard area - eg. on animated popups and drop in update notices that still scare the living heck out of you when you ("successfully updated"). It's like a halloween party every time, you know there is a scare around the corner its just when :slight_smile:

    For the hub, when that "update fail error appears, and if I am at the letter "s" on the alphabet of infinite scroll table of websites for my website updates - which is quite a lengthy list - whoosh...I am sent to the top of the WPMU dungeon for my sins to read the banner error message - and made to start over.

    So apart from the horror of WPMU animations, yes, I thought this would have been fixed by now and months later, it's just become rather annoying as I have a lot of websites to maintain.

    Any assistance from the WPMU grim reaper plugin team would be scarily appreciated.

    Cheers
    Mark

  • Adam Czajczyk

    Hello Mark!

    I noticed that you did not assign any site to this thread and you've got indeed a lot of domains registered so I'm not sure about which one(s) is/are the one(s) in question. I'm asking because I'm wondering what are the WordPress and WPMU DEV Dashboard versions used on these sites. Could you please check this and let me know?

    Just like my colleague Predrag said, I remember experiencing this issue in the past (even on my test sites) but we didn't come across it for some time already and I'd like to make sure whether this may or may not be related to WP and plugin releases.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.