Plugins Upgrade Error

I finally got my site moved but now I want to deal with a problem regarding plugins. I actually had this problem before the move also.

Whenever I upgrade a plugin automatically I get the following error message:

Cannot modify header information - headers already sent by (output started at /home/*****/public_html/wp-admin/admin-header.php:18) in /home/++++++raissen/public_html/wp-includes/pluggable.php on line 868

This happens with all plugins but they still seem to work. But I know I need to take care of this before things get worse or it creates major problems after the site in heavily populated.

Thanks,

Sleenie