Poor site performance (32/100)

Hi
I've just installed WPMU and enabled WPSmush & Hummingbird, as users were complaining about poor site performance. I've Smushed all the images and followed most of the Hummingbird recommendations, but it didn't make a lot of difference. I've also emailed our host as there was an issue with Gzip compression ("Your server may not have the "deflate" module enabled (mod_deflate for Apache") . Not sure what to do next at all. Can you advise?

  • Nastia

    Hello Steve

    Hope you are doing well!

    If mod_deflate is not enabled on your site, please ask your hosting provider to enable it.

    Please locate the .htaccess file, edit it and add the following rules manually at the bottom

    <IfModule mod_deflate.c>
        <IfModule mod_setenvif.c>
            <IfModule mod_headers.c>
                SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
                RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
            </IfModule>
        </IfModule>
        <IfModule mod_filter.c>
            AddOutputFilterByType DEFLATE "application/atom+xml" \
                                          "application/javascript" \
                                          "application/json" \
                                          "application/ld+json" \
                                          "application/manifest+json" \
                                          "application/rdf+xml" \
                                          "application/rss+xml" \
                                          "application/schema+json" \
                                          "application/vnd.geo+json" \
                                          "application/vnd.ms-fontobject" \
                                          "application/x-font-ttf" \
                                          "application/x-font-opentype" \
                                          "application/x-font-truetype" \
                                          "application/x-javascript" \
                                          "application/x-web-app-manifest+json" \
                                          "application/xhtml+xml" \
                                          "application/xml" \
                                          "font/eot" \
                                          "font/opentype" \
                                          "font/otf" \
                                          "image/bmp" \
                                          "image/svg+xml" \
                                          "image/vnd.microsoft.icon" \
                                          "image/x-icon" \
                                          "text/cache-manifest" \
                                          "text/css" \
                                          "text/html" \
                                          "text/javascript" \
                                          "text/plain" \
                                          "text/vcard" \
                                          "text/vnd.rim.location.xloc" \
                                          "text/vtt" \
                                          "text/x-component" \
                                          "text/x-cross-domain-policy" \
                                          "text/xml"
    
        </IfModule>
        <IfModule mod_mime.c>
            AddEncoding gzip              svgz
        </IfModule>
    
    </IfModule>

    In case mod_deflate is enabled, and GZIP still not working, please deactivate all the other plugins except Hummingbird and see if the GZIP compression will work. Then activate one plugin at a time, till you find the one that affecting GZIP compression.

    If the issue still persists, please grant access from WPMU DEV > Support so I can have a closer look?

    Please see the detailed instructions on the link below:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    I've tested your site performance with Google Page Speed Insight, and Minification feature will help to improve the following performance for:
    - Eliminate render-blocking JavaScript and CSS in above-the-fold content
    - Minify CSS
    - Minify JavaScript

    The Leverage browser caching score can be improved by enabling Browser Caching feature in Hummingbird

    To improve your site's performance please have a look at the following useful articles:
    Make Your WordPress Site FLY with Hummingbird

    How to Eliminate Render-Blocking Issues With Hummingbird for WordPress
    Fast Gets Faster as Hummingbird Adds CloudFlare Integration

    Fast Gets Faster as Hummingbird Adds CloudFlare Integration

    Please let me know when the support access will be active :slight_smile:

    Cheers,
    Nastia

  • Majid

    Hello Steve :slight_smile:
    I hope you are doing great today !

    I checked the performance score and it seems to be improved and GZIP is now enabled. I also noticed that you are using W3 Total cache, which might be the reason why you didn't see the scan results right away as you were served cached content.

    And feel free to let us know if you are still having issues with your site speed :slight_smile:

    Cheers,
    Majid

  • Nastia

    Hello Steve

    Hope you are doing well!

    The score for Remove render blocking resources can still be increased from Minification. You will need to move the JS files position to the Footer. Please do it one file at the time, each time checking the front end for changes

    Although the Minification is not working properly n your site. Most of the site has "Pending" or "Ignored" status. This most likely because the Minification in W3 Total Cache is active. To avoid conflicts please deactivate the minification for CSS and JS files in Performance > Minify.

    Once the minify feature is deactivated, deactivate the CDN option for:
    - Host minified CSS and JS files
    - Host theme files

    Since CDN option is active for in Minification <- Hummingbird this might cause conflicts and lower your loading speed.

    After this, please move the JS position into the footer give about 5 minutes for each file to be uploaded to CDN to see the difference and run the performance report.

    Let us know how it went!

    Cheers,
    Nastia