Pop Over plug-in problem

Hi,

Having a problem getting my pop over ad to display.

I've used the plugin without problems on a single Wordpress site - so I know it works. However, on my multi-site I find there is an issue.

The plug-in seems to work until I add the "rule" based how many times the ad should display.
This rule seems to break the plugin.

And then, when I log back in, I see that the "rule" "Ad displays less than ___ times"
has vanished.

It seems to work fine with the rule "show for non-logged in user," but then keeps displaying over and over!

Here is my site:
http://netppl.biz

Thanks!

  • James Farmer
    • CEO (of WPMU DEV, honest)

    Hi dlittle800,

    I've tagged Barry here as it's his baby, but he may not be around for a while (its kinda late in Spain!) so 'pologies for any delay.

    Few questions:

    - Is it as an mu-plugin or a regular plugin (activated network wide)?
    - Are you having the issue on a root blog or a sub directory blog?

    It sounds like it might not be storing that variable in the database ok... are you any good with phpmyadmin (to take a look?)

    Cheers, James

  • dlittle800
    • WPMU DEV Initiate

    Hi James,

    I'm currently just using the Pop over plugin on my main site.

    The plugin has been installed as per the instructions:

    1) Place the popover.php file in the mu-plugins directory
    2) Place the popoverincludes in the mu-plugins directory

    The, I go to SuperAdmin/Popover
    Adda rule - but it doesn't show.

    I'll take a look at phpmyadmin

    Also, I noticed that in the SuperAdmin/Povers screen, there is an ending tag lingering at the top above "Edit Popover Settings"

    Could this be related to the problem?

    Thanks.

  • dlittle800
    • WPMU DEV Initiate

    Hi James/Barry,

    @James - did you mean that Barry on a trip to Spain and will be away for days/weeks? Or did you mean he lives in Spain and will be away from his computer for awhile?

    I checked my database:

    Checked in global database in wp_sitemeta table.
    Here're popover-related meta_key entries from that table:
    popover_content
    popover_size
    popover_location
    popover_usejs
    popover_check
    popover_colour
    popover_margin
    popover_count

    Thanks, Derek
    http://netppl.biz

  • dlittle800
    • WPMU DEV Initiate

    That's it exactly Barry.

    And that's how the site stands right now - plugin installed, activated, added rule, no popover.

    I have a developer who set it up for me - and he's setup over 70 plugins for me so he really knows what he's doing.

    He did get it working for me - but the popup appeared on every page. So I added the rule to limit the number of views to "1." Then , it stopped working.

    He reinstalled it, and I tried again. This time I set it to "2." Same result.

    Thanks, Derek

  • dlittle800
    • WPMU DEV Initiate

    Hi Barry,

    I installed Explorer 8 for the first time and the popover still didn't work.

    I'm guessing the problem is a plugin conflict.

    I have over 100 plugins installed in my site (mainly for testing purposes).
    I'll be deleting 3/4 of them soon and that may eliminate the conflict.
    http://netppl.biz

    Maybe you know of some existing conflicts? If so, I probably have that plugin installed : )

    Will keep you updated.

    Thanks, Derek

  • Mason
    • DEV MAN’s Sidekick

    Hiya Derek,

    I'm also noticing a javascript error on the front end of your site. It has to do with thickbox, but I wasn't able to sort the cause of the error beyond that.

    If you're able, I'd recommend disabling all plugins except the popover plugin. Then test and see if the issue still exists. If it does, then we have something to sort out here. If it starts to work, you know for sure it's a plugin conflict and can activate each plugin one at a time to find the plugin (could be more than one) that is causing the problem here.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.