Pop Over Plugin NOT in GREEKS

Hello,
Ive downloaded the Pop-Up plug-in but i cannot write in Greeks.
The message in the pop-up apears with question marks (???????? like this).
So, is there any solution?
Thank you,

Vasilis Pappas
Greece

  • Zyniker
    • WordPress Warrior

    I'll be honest, I don't think my Greek is sufficient to be of particularly great help here. However, if the issue is that when you type a message into the popup generated by the Pop Up! plugin, you are seeing symbols instead of Greek, then it would seem that there is some code in the plugin that will need to be changed to accommodate Greek.

    With that in mind, it may be best to get the developer (@Barry) in here.

  • aecnu
    • WP Unicorn

    Greetings Vasilis,

    Thank you for bringing this significant item to our attention.

    Please try adding AddDefaultCharset UTF-8 To your htaccess file and if that does not do the job I will indeed have to ping the lead developer Barry in here for his advice/advise as to what may be causing this issue.

    Please advise.

    Cheers, Joe

  • vaspappas
    • WPMU DEV Initiate

    Hello aecnu and thank you for your interest,
    Where do i locate the htaccess file ..and where do i put the code you gave me?
    (sorry Im not an advanced user).
    Thank you again for you help.
    Happy new Year from Greece!
    Best,

    Vasilis

  • aecnu
    • WP Unicorn

    Greetings Vasilis Happy New Year!

    The htaccess file is located (or should be located) in the root folder of your WordPress installation.

    Please advise if that indeed gets your issue resolved.

    Looking forward to hearing form you in any event and have a GREAT New Year!

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Vasilis,

    Just following up seeing that you cannot see the htaccess file are you using an FTP client that has hidden files enabled? So that you can indeed see the file if present?

    This is what seems to be the issue at the moment locating the htaccess file. We could indeed recreate one but if in fact there is one there already that we just cannot see then the recreation could over write the current one causing further grief.

    Please advise (If necessary and your permissions I will FTP in and check it out myself)

    Cheers, Joe

  • Natasa82
    • WPMU DEV Initiate

    Hi there
    I have the same problem with Greek characters. I was able to find the htaccess file and pasted the "AddDefaultCharset UTF-8" but nothing happened. Unless I located it in the wrong spot?

    The code in the htaccess file is

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    I put the "AddDefaultCharset UTF-8" right before the # BEGIN WordPress at first and right after the # END WordPress in my second try.Should I put it elsewhere?

    thank you in advance
    Natasa

  • aecnu
    • WP Unicorn

    Greetings Vasilis and Natasa,

    @Natasa82 thank you for your input and right before the # BEGIN is absolutely the correct place.

    @Vasilis and Natasa after some heavy digging in I found the answer in which is is not the "add default character set" as I originally thought might fix this but indeed database table collation.

    You need to adjust the collation for the database table for popover from latin to UTF8_general_ci and that should fix the issue though you may need to retype the text in and save it again after the change has been made.

    Here is how collation is changed if done in phpMYadmin:
    http://answers.yahoo.com/question/index?qid=20090319040418AAGvbXz

    Which should be part of your hosting control panel.

    Please advise if this works for you folks as I anticipate.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Vasilis and Natasa,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU DEV Community Member!

    Cheers, Joe

  • Natasa82
    • WPMU DEV Initiate

    @aecnu

    thanks for your reply,
    I still haven't tried to adjust the collation for the database table for popover as you instructed because I'm facing problems with accessing phpmyAdmin....
    once this is resolved I will let you know if your instructions helped me.
    Natasa

  • Dimis13
    • WPMU DEV Initiate

    ??,

    I had the same issue with the Greek characters as @vaspappas.
    The problem was the collation of the table "wp_popover" [also "wp_popover_ip_cache" table], which were in Latin1_swedish_ci.
    So i changed it to UTF8_general_ci, as also @aecnu suggested.

    What i noticed is that, some tables of WPMUDEV plugins, are created with the collation the database has. Some other Wpmudev plugin tables are created automatically in UTF8_general_ci collation, independently of the database collation.

    In my case, i had installed my database with Latin1_swedish_ci collation, and so, the same collation took the "wp_popover" table, when i installed the plugin. In a second test wordpress installation with database in UTF8_general_ci, the "wp_popover" table took the UTF8_general_ci collation.
    In the first case, the problem was that, even when i changed the "wp_popover" collation, the problem with the ?????? characters continued. And what i did, was to re-install the wordpress setting the database collation to UTF8_general_ci.

  • Instadesign
    • WPMU DEV Initiate

    Why is are the tables for the plugin still set to Swedish? Is an updated version of the plugin with this issue addressed being released sometime soon? I'm pretty annoyed that I've just had to waste an hour of my time investigating and fixing this when the issue was flagged up a year ago, and you seem to be very proud of the quality of your plugins which people are paying good money for!

  • Alexander
    • DEV MAN’s Mascot

    Hi @Instadesign,

    Pop up doesn't automatically set the collation to Latin1. It checks to see if one is defined in WordPress settings and uses that. If not, it goes ahead and uses the default collation from your server's MySQL settings. So occasionally, this issue can arise with any plugin that might add custom database tables.

    Best regards,

  • PC
    • WPMU DEV Initiate

    Hey there,

    Thanks for posting back.

    We suggest to open up a new thread for new issues so that we can track and support accordingly. This is a pretty old thread to keep the discussion going on. For better support and fast turnaround times, kindly create a new one :slight_smile:

    Pop Over and Pop Up are same plugins which we offer.

    Cheers, PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.