Pop Over Plugin problem

When I hit 'Update' button I get redirected:

1. To the log-in page of one of my sites (user site)
2. To the main site's dashbord (after I deactivated that site from above)

Also, plugin's text field does not save information bellow:

<a href="http://site.com/something/"><img class="alignleft size-full wp-image-2185" title="need_portfolio" src="http://site.com/files/2011/02/image.jpg" alt="" width="500" height="200" /></a>

Even if I don't put any code in text area same thing happens.

Maybe I should mention that site from 1. was actually a members site with BuddyPress plugin activated. But I had many upgrades since then. And I doubt that it has anything to do with this cause I still get redirected to the main site's dashboard.

  • Philip John
    • DEV MAN’s Apprentice

    Heya Marko!

    So, first off it'd really help if you could provide some information about your set-up. That way I can better understand and help you to sort this issue out :slight_smile:

    So,
    - What version of WordPress are you using?
    - What version of the Pop Over plugin are you using?
    - Have you tried to hit Update with all other plugins de-activated?
    - What theme are you using?

    Let me know those and we'll go from there... one step at a time!

    Best,
    Phil

  • Marko
    • Design Lord, Child of Thor

    Thanks a lot Phill.

    Yes, that plugin is very useful cause it lets you add all users to one or more sites. I didn't want to install any forum plugin cause so I created a site (with P2 theme) where members get support.

    But now I'll activate dsader's Add Users Sidebar Widget.

    Cheers,
    Marko

  • Marko
    • Design Lord, Child of Thor

    Wooops! Looks like I gave you wrong information. It's not working again. I've deactivated all plugins and again activated just PopUp plugin and it's not working. Sorry for previous two mails.

    When I said that that MUM plugin was causing it I thought that it really was cause I deactivated it and tried PopUp's 'Update' button few times and no redirection happened. So I thought it's cool. But it's not:slight_frown:

  • Philip John
    • DEV MAN’s Apprentice

    Hmmm okay...

    One more question: you say the information you enter doesn't get saved... So when you visit the site do you see the pop up appear or does nothing happen?

    I assume nothing as that makes sense, but you never know... :wink:

    Hopefully Barry will chime in when he's around and provide some thoughts, too.

    Phil

  • Marko
    • Design Lord, Child of Thor

    Tried it. Not working. I does not save text. It also can't 'Remove' values bellow. Just adds '#remove' to the address in browser. I still get redirected to site's Dashboard.

    I'm logged in on the main site as Super Admin.

  • Barry
    • DEV MAN’s Mascot

    Ok, can you give me details of where you have it installed - file path and how you have it activated (single - network, via mu-plugins).
    Can you try using Firefox with the Firebug browser extension on it http://getfirebug.com/

    If you load the admin page with the firebug screen open and on the Net tab it will show you what is loading - anything coloured red is bad - missing file.

  • Marko
    • Design Lord, Child of Thor

    Barry, sorry for waiting... Plugin was activated on that site but I don't know why you idn't see it.... but I'm on to something. First I've installed the plugin like this:

    ===
    1) Place the popover directory in the plugins directory
    2) Activate the plugin
    ===

    I already wrote above what has happened. Options for it appeared under Super Admin menu, not under Settings menu. I swear I downloaded latest version few times. Then I deactiveted it and deleted it. Came home from the agency and downloaded it again. This time I did this

    ===
    1) Place the popover.php file in the mu-plugins directory
    2) Place the popoverincludes in the mu-plugins directory
    For blog by blog control - comment out the PO_GLOBAL line at the top of the plugin file.
    ===

    Plugin options appeard under Settings menu. Interface looks totaly different.

    Then I deactivated and deleted it and tryed that first installation instructions again. Looks like it works although I can't see popup in Firefox, only in Chrome. So I guess it works now and looks like Barry (White) did save my life in the end:slight_smile:

    Thanks for your effort,
    Marko

  • Barry
    • Flash Drive

    Tried all of this, still doesn't work. I was having same issue as Marko, tried his fix, but no good results.

    On wpmu, just upgraded to 3.05, upoaded popover includes and popover.php to mu-plugins directory--- popover options shows in settings as I suppose it is meant to, and options layout seem to correctly display. But no popup appears with different browsers, cleared cache, etc.

    As well, by putting only those files as stated above, there is no "plugin" to activate or deactivate as it is not listed in plugins (but the options do exist in "settings").

    If I install the popover plugin to the plugin directory via uploader, it (the plugin) can be seen but it can't be activated because it causes a "fatal error" by calling functions from both instances of the "includes" folder which exist in different directories--- plugins and mu-plugins.

    So, can anyone explain exactly what goes where or possible permissions? This is WPMU 3.0.5, and buddypress 1.2.7.

    thank you in advance!

  • Barry
    • DEV MAN’s Mascot

    @clickdaddy -

    As well, by putting only those files as stated above, there is no "plugin" to activate or deactivate as it is not listed in plugins (but the options do exist in "settings").

    If you placed it in mu-plugins you won't have a plugin to activate - it automatically is.

    If I install the popover plugin to the plugin directory via uploader

    We recommend FTPing to your server - never use the uploader built into WP

  • Barry
    • Flash Drive

    Thank you for your response. I should have added that I tried FTP several times first.

    So, In the case I have stated... you are saying that I need only to FTP, the popover "includes folder" and the popover.php file into the mu-plugins folder and this will work? Meaning nothing else has to be put anywhere?

    If that is the case, I will have a starting point to work with. Any suggestions as to permissions on these files?

    Again, thank you!

  • Barry
    • DEV MAN’s Mascot

    popover "includes folder" and the popover.php file into the mu-plugins folder and this will work

    Yes, or copy the popover directory to the plugins directory and activate it in the admin area, or click on network activate if you want it to run across all sites.

  • Barry
    • Flash Drive

    copy the popover directory to the plugins directory and activate it in the admin area

    doing that is what causes exactly the same problem as Marko initially had above.

    popover "includes folder" and the popover.php file into the mu-plugins folder and this will work

    It gives you the proper admin layout, but popovers don't work on the site. Either way, I can't make it work.

    I appreciate your help, but I am at a loss at where else to go with this

  • Barry
    • Flash Drive

    copy the popover directory to the plugins directory and activate it in the admin area

    doing that is what causes exactly the same problem as Marko initially had above.

    popover "includes folder" and the popover.php file into the mu-plugins folder and this will work

    It gives you the proper admin layout, but popovers don't work on the site. Either way, I can't make it work.

    I appreciate your help, but I am at a loss at where else to go with this

  • Barry
    • DEV MAN’s Mascot

    It gives you the proper admin layout, but popovers don't work on the site

    Can you clear the cookies in a browser and see if it helps? Also, can you post up the rules you have set for the popover (screenshot would be fine).

    Finally, can you activate the theme testing plugin that is included in the Download and let me there are any theme related messages showing on your admin area?

  • UNIIMI
    • The Incredible Code Injector

    I am having the exact same problem.

    Could not get the settings to save per the installation instructions.

    The admin area does work when using the instructions from Marko! Yay!

    1) Place the popover.php file in the mu-plugins directory
    2) Place the popoverincludes in the mu-plugins directory
    For blog by blog control - comment out the PO_GLOBAL line at the top of the plugin file.

    I am now able to save my settings, go to another admin page, return to this one and still see my settings. Yay!

    I still can't get the darn pop over to load in a browser though!

    From my main computer on Windows in Firefox I have cleared everything. In IE I have cleared cookies and deleted the entire browsing history. Tried it in Chrome, deleted everything. Tried it in Safari, deleted everything. Then I even tried it from a different computer in my house that had never been to my site before (Mac w/ Safari). No luck any which way I try. :slight_frown:

    Then I removed all the rules except "Visitor is not logged in" AND IT WORKED!

    Added "Visitor is logged in" no worky :slight_frown:

    Added "Popover shown less than" (10 times) - still nada

    Went back to just "Visitor is not logged in" AND IT WORKED!

    Running a Multisite with BuddyPress 1.2.7 on WP 3.0.5. http://uniimi.com/

    Please help!

  • Barry
    • DEV MAN’s Mascot

    Then I removed all the rules except "Visitor is not logged in" AND IT WORKED!
    Added "Visitor is logged in" no worky :slight_frown:

    A user can't be both logged in and not logged in, so it's not going to show - the rules are AND rules, so all must be true for the popover to show.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.