Pop-Over rule for search engine not working for Google

Greetings, I'm using Pop-Over 4.5.3 on WP 3.9.2. Three rules in place:

1 - Visit via a search engine
2 - On specific URL
3 - Show on user exit attempt

Rule 1 fires for Bing and Yahoo, but not Google. Need your recommendation to get Rule 1 working for Google. Also, is Rule 1 designed to handle ad referrals, such AdWords?

  • Patrick

    Hi there @Ron

    Welcome to the forums, glad to have you aboard!

    As far as I am aware, the "Visit via a search engine" rule should work for any visitor who arrives at your site from the search results of any SE.

    So I do not think it would do the trick for those who click through from ads on the search results. Then again, I may be wrong... it's been known to happen. :wink:

    I believe the function you are referring to in your 2nd post has been moved to popover/popoverincludes/classes/popoverajax.php around line 383

    And yes, that has been updated since the thread you visited, which is almost 3 years old, so really is not valid anymore as a reference:
    https://premium.wpmudev.org/forums/topic/no-pop-up-for-google-vistors#post-725103

    Oh, and when posting a reference to another thread, please post the entire link. Just the post number really doesn't help as we have no way to find it with just that number, and must search for context (yay, Google!). :slight_smile:

  • Ron

    I've done some additional testing to try an isolate the Google issue. I've discovered that Chrome and IE are using https when on Google pages, and searches from https Google pages does not trip the search engine rule. However, if I remove the https, do the same search and use the same link, the search engine rule trips for Google. Similarly, Chrome and IE were using only http for Bing and Yahoo, so the search engine rule always tripped.

    If you can advise a fix to recognize both https and http, I think that would do it.

  • Ron

    Hi Ash, thanks for this. A couple of issues after deleting 4.5.x and installing 4.6:

    1. My original popup was in the popup section.
    2. There was no option for "on exit" selected or in list.
    3. When using Add Image, the media library just spins, never opens.
    4. The following WARNING is displayed at top of screen:
    Warning: session_start(): open(\xampplite\tmp\sess_2hv7tou3jg00a442fc5iim0rs5, O_RDWR) failed: No such file or directory (2) in J:\_Web_Dev\www.metroalloysinc.dev\wp-content\plugins\popover\inc\external\wpmu-lib\functions-wpmulib.php on line 73
    5. I deleted and re-installed 4.6 with all the same results above.

    I appreciate you re-looking at this and updating the 4.6 release as needed.

  • Patrick

    Hi again @Ron

    I hope you had a great weekend!

    1. My original popup was in the popup section.

    I'm wondering if this may be due to your site being on a local install.

    2. There was no option for "on exit" selected or in list.

    That "On exit" and "On click" rules have been combined into a single new one: "Javascript events". Once enabled, you'll find the settings in the "Behavior" section when creating/editing a popup.

    3. When using Add Image, the media library just spins, never opens.
    4. The following WARNING is displayed at top of screen:

    These may be related; perhaps the plugin isn't installing fully, perhaps your tmp folder is not writable, perhaps your php.ini file is for the wrong OS (Linux, Windows, etc.)

    Can you please look into those potential causes and let us know your findings?

    Thanks!

  • Ron

    Thanks for your reply, Patrick.

    I see the change for "on exit" now. It the Javascript Event was checked, but didn't connect the needed addition in the Behavior section.

    As for Add Image and the WARNING message -- the 4.6 release is running on the same OS (Win7) and server as 4.5.x previously. This is same development/testing environment I use for numerous websites. There have been no changes to the environment, and I'd need much more specific direction on what you want me to check to verify a full 4.6 install, or anything in php.ini and tmp folder.

    I look forward to your further direction.

  • Ash

    Hello @Ron

    It seems a conflict.

    1. Logout from admin, delete browser cache and login again.
    2. Would you please enable debug mode and check if any error is shown in that page? ( I think it is enabled though as you are seeing a warning)

    To enable debug mode please edit a line in your wp-config.php:
    Change

    define('WP_DEBUG', false);

    to

    define('WP_DEBUG', true);

    3. Please right click on chrome browser > Select Inspect Element > Select console tab > Refresh the page > add a media and check if any error is shown in the console.

    Please let us know about the error.

    Cheers
    Ash

  • Ron

    Hi Ash -- below are a series of DEBUG lists and last below the inspect/console results. Hope this is what you're looking for ... after all steps ... the Add Image still spins without ever displaying library.

    Here is the DEBUG that appeared above the WP login:

    Notice: get_settings is deprecated since version 2.1! Use get_option() instead. in J:\_Web_Dev\metroalloysinc-copy.dev\wp-includes\functions.php on line 3078

    Strict Standards: Static function Popover_Rules_Rule::add() should not be abstract in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\popover\popoverincludes\includes\functions.php on line 447

    Notice: Use of undefined constant QUOTE_ROTATOR_VERSION - assumed 'QUOTE_ROTATOR_VERSION' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 27

    Notice: Use of undefined constant QUOTE_ROTATOR_DATABASE_VERSION - assumed 'QUOTE_ROTATOR_DATABASE_VERSION' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 29

    Notice: Use of undefined constant QUOTE_ROTATOR_DATABASE_TABLE - assumed 'QUOTE_ROTATOR_DATABASE_TABLE' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 32

    Notice: Use of undefined constant QUOTE_ROTATOR_I18N - assumed 'QUOTE_ROTATOR_I18N' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 36

    Notice: Use of undefined constant QUOTE_ROTATOR_PATH - assumed 'QUOTE_ROTATOR_PATH' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 44

    Notice: Use of undefined constant QUOTE_ROTATOR_CLASS_PATH - assumed 'QUOTE_ROTATOR_CLASS_PATH' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 46

    Notice: Use of undefined constant QUOTE_ROTATOR_IMAGE_URL - assumed 'QUOTE_ROTATOR_IMAGE_URL' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 58

    Notice: Use of undefined constant QUOTE_ROTATOR_JS_URL - assumed 'QUOTE_ROTATOR_JS_URL' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 60

    Notice: Use of undefined constant NAUGHTY_MESSAGE - assumed 'NAUGHTY_MESSAGE' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 64

    Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method collapsCat::init_textdomain() should not be called statically in J:\_Web_Dev\metroalloysinc-copy.dev\wp-includes\plugin.php on line 470
    Metro Alloys, Inc.

    Here is the DEBUG that appears on the Pop-Over edit page:

    Strict Standards: Only variables should be passed by reference in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\backupbuddy\pluginbuddy\_pluginbuddy.php on line 84

    Notice: get_settings is deprecated since version 2.1! Use get_option() instead. in J:\_Web_Dev\metroalloysinc-copy.dev\wp-includes\functions.php on line 3078

    Strict Standards: Static function Popover_Rules_Rule::add() should not be abstract in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\popover\popoverincludes\includes\functions.php on line 447

    Notice: Use of undefined constant QUOTE_ROTATOR_VERSION - assumed 'QUOTE_ROTATOR_VERSION' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 27

    Notice: Use of undefined constant QUOTE_ROTATOR_DATABASE_VERSION - assumed 'QUOTE_ROTATOR_DATABASE_VERSION' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 29

    Notice: Use of undefined constant QUOTE_ROTATOR_DATABASE_TABLE - assumed 'QUOTE_ROTATOR_DATABASE_TABLE' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 32

    Notice: Use of undefined constant QUOTE_ROTATOR_I18N - assumed 'QUOTE_ROTATOR_I18N' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 36

    Notice: Use of undefined constant QUOTE_ROTATOR_PATH - assumed 'QUOTE_ROTATOR_PATH' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 44

    Notice: Use of undefined constant QUOTE_ROTATOR_CLASS_PATH - assumed 'QUOTE_ROTATOR_CLASS_PATH' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 46

    Notice: Use of undefined constant QUOTE_ROTATOR_IMAGE_URL - assumed 'QUOTE_ROTATOR_IMAGE_URL' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 58

    Notice: Use of undefined constant QUOTE_ROTATOR_JS_URL - assumed 'QUOTE_ROTATOR_JS_URL' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 60

    Notice: Use of undefined constant NAUGHTY_MESSAGE - assumed 'NAUGHTY_MESSAGE' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 64

    Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method collapsCat::init_textdomain() should not be called statically in J:\_Web_Dev\metroalloysinc-copy.dev\wp-includes\plugin.php on line 470

    Strict Standards: Non-static method GFCommon::all_caps() should not be called statically in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\gravityforms\gravityforms.php on line 112

    Strict Standards: Non-static method GFCommon::get_base_path() should not be called statically in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\gravityforms\gravityforms.php on line 114

    Strict Standards: Non-static method GFCommon::all_caps() should not be called statically in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\gravityforms\gravityforms.php on line 533

    Strict Standards: Non-static method GFCommon::get_base_url() should not be called statically in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\gravityforms\gravityforms.php on line 544

    Notice: Undefined index: userhash in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\backupbuddy\pluginbuddy\lib\updater\updater.php on line 407

    Notice: Undefined index: username in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\backupbuddy\pluginbuddy\lib\updater\updater.php on line 408

    After right-click and refresh, here is what appeared in the console:

    Strict Standards: Only variables should be passed by reference in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\backupbuddy\pluginbuddy\_pluginbuddy.php on line 84

    Notice: get_settings is deprecated since version 2.1! Use get_option() instead. in J:\_Web_Dev\metroalloysinc-copy.dev\wp-includes\functions.php on line 3078

    Strict Standards: Static function Popover_Rules_Rule::add() should not be abstract in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\popover\popoverincludes\includes\functions.php on line 447

    Notice: Use of undefined constant QUOTE_ROTATOR_VERSION - assumed 'QUOTE_ROTATOR_VERSION' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 27

    Notice: Use of undefined constant QUOTE_ROTATOR_DATABASE_VERSION - assumed 'QUOTE_ROTATOR_DATABASE_VERSION' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 29

    Notice: Use of undefined constant QUOTE_ROTATOR_DATABASE_TABLE - assumed 'QUOTE_ROTATOR_DATABASE_TABLE' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 32

    Notice: Use of undefined constant QUOTE_ROTATOR_I18N - assumed 'QUOTE_ROTATOR_I18N' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 36

    Notice: Use of undefined constant QUOTE_ROTATOR_PATH - assumed 'QUOTE_ROTATOR_PATH' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 44

    Notice: Use of undefined constant QUOTE_ROTATOR_CLASS_PATH - assumed 'QUOTE_ROTATOR_CLASS_PATH' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 46

    Notice: Use of undefined constant QUOTE_ROTATOR_IMAGE_URL - assumed 'QUOTE_ROTATOR_IMAGE_URL' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 58

    Notice: Use of undefined constant QUOTE_ROTATOR_JS_URL - assumed 'QUOTE_ROTATOR_JS_URL' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 60

    Notice: Use of undefined constant NAUGHTY_MESSAGE - assumed 'NAUGHTY_MESSAGE' in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\quote-rotator\quote-rotator.php on line 64

    Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method collapsCat::init_textdomain() should not be called statically in J:\_Web_Dev\metroalloysinc-copy.dev\wp-includes\plugin.php on line 470

    Strict Standards: Non-static method GFCommon::all_caps() should not be called statically in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\gravityforms\gravityforms.php on line 112

    Strict Standards: Non-static method GFCommon::get_base_path() should not be called statically in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\gravityforms\gravityforms.php on line 114

    Strict Standards: Non-static method GFCommon::all_caps() should not be called statically in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\gravityforms\gravityforms.php on line 533

    Strict Standards: Non-static method GFCommon::get_base_url() should not be called statically in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\gravityforms\gravityforms.php on line 544

    Notice: Undefined index: userhash in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\backupbuddy\pluginbuddy\lib\updater\updater.php on line 407

    Notice: Undefined index: username in J:\_Web_Dev\metroalloysinc-copy.dev\wp-content\plugins\backupbuddy\pluginbuddy\lib\updater\updater.php on line 408

  • Michael Bissett

    Hey @Ron,

    Those notices you posted there don't look to be the problem. Thinking back to what you said earlier about that warning you got, there's a problem area (highlighted below):

    Warning: session_start(): open(\xampplite\tmp\sess_2hv7tou3jg00a442fc5iim0rs5, O_RDWR) failed: No such file or directory (2) in J:\_Web_Dev\www.metroalloysinc.dev\wp-content\plugins\popover\inc\external\wpmu-lib\functions-wpmulib.php on line 73

    That path I highlighted is missing the drive letter (which is why you're getting the "No such file or directory", since the path it's presently looking for isn't valid).

    If drive J:\ is where you have XAMPP installed, open your php.ini (back it up first please!), and change \xampp\tmp to J:\xampp\tmp. Restart the server, and you should be good to go on that front. :slight_smile:

    Now, if you're still having issues with the media library continually showing that spinner, I'd like to ask if you've tried disabling the other plugins on your site, just to see if any of them are getting in the way here?

    Please advise,
    Michael

  • Ron

    Thanks for your reply, Michael.

    Actually, XAMPP is on drive c: -- the dev website is on drive j: -- and I do see xampplite\tmp\sess_2hv7tou3jg00a442fc5iim0rs5 on drive c:

    That said and before making any changes, should the change be made to the server xampplite\php\php.ini -- or somewhere in the popover code? I've not run into this issue with any of the other WP plugins. Will this be a non-issue when added to the live site?

  • Michael Bissett

    Hey @Ron,

    That said and before making any changes, should the change be made to the server xampplite\php\php.ini -- or somewhere in the popover code?

    In the server php.ini file. I would recommend making a backup first though, just to be safe here. :slight_smile:

    I've not run into this issue with any of the other WP plugins. Will this be a non-issue when added to the live site?

    It shouldn't be an issue once you push to live, this is something that's showing up due to the nature of your local configuration.

    Hope this helps! :slight_smile:

    Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.