Pop Overs - how to set "not on the home page"?

I'm having trouble with the Pop Overs (Pop Up!) plugin.

I've got a pop up working well with 3 criteria:
Visitor is not logged in
Popover shown less than x times
Not on specific URL

It all works perfectly until ... I try to add the home page to the list of URLs to exclude.

I have tried adding the whole domain name. And I have tried adding just "/" for the home page. Both of these options cause the Pop Over to immediately stop working.

The other URLs I have specified to exclude a relative - e.g. "/category/*" and that works fine.

But trying to add the home page causes the Pop Over to stop working on all pages.

Hopefully there's an easy answer.

Thanks!
Josh