Pop Up! Plugin Note Working At All

I just downloaded the Pop UP! plugin and it is not working at all. I’ve tried the free version and it never worked right. Upgraded to the pro version and it won’t work either. This is our test site: http://rgm.me/Wordpress_Test/. However, once we have it fixed and ready, we want to move it to the main site (without the folder). Tried it on that and it didn’t work either. I’ve tried it with ever condition combination possible. Right now I don’t have any on at all. Can you please help. I’ve been trying to get a pop up on the site for nearly three weeks now.

  • crestfalleen
    • Flash Drive

    I’ve reset some things and I got it working on the test site. I’m about to check it on the main site. I don’t know what I did, but it’s working now. I just changed the conditions again and it worked. Give me a bit and let me test it on the main site and I’ll let you know. But thank you so much for the quick response. You guys totally rock.

  • crestfalleen
    • Flash Drive

    So I got it popping up and it works great for that. However, I have my conditions set for “Visit Not Via An Internal Link” so they’ll only see it on the first page they come to on our website and “Popover Shown Less Than” set to “2 times” just to not annoying everyone. I did have it set to also show only when a “visitor is logged in” so I could test it, however I just took that off so you can take a look. With those in place, I’d assume it would only appear once (either the home page or any page they came to from an external link, like our email newsletter). However, when I’m clicking around the site it keeps popping up. When I open a new tab and go to the home page it sometimes doesn’t show, buit I go to another page and it does. Then I continue to jump around to pages and I get it on different pages as I click through. Do I have everything set right or am I missing anything? I also clear my cache after I make any changes so that shouldn’t effect it. Thanks so much.

  • crestfalleen
    • Flash Drive

    I’m checking it on 3 computers, my Mac desktop and a PC and Mac laptop. The two laptops are showing the cookies “Content” at 2, buit they keep popping up. The desktop however has totally messed up on the page. The pop up shows up (not sure how much, I haven’t gotten past this) and the webpage is missing text, graphics, slideshow, etc. Not sure what is up with that. I’m attaching a screenshot though. I may just need to restart my browser. But the cookies are just showing 2, when they pop up a lot more than that. Thanks.

  • crestfalleen
    • Flash Drive

    I looked into the error with the header. I’m running a child theme on the Genesis Framework and on the Genesis header.php, the code is the following:

    <?php

    /**

    * WARNING: This file is part of the core Genesis framework. DO NOT edit

    * this file under any circumstances. Please do all modifications

    * in the form of a child theme.

    *

    * Handles the header structure.

    *

    * @package Genesis

    */

    do_action( ‘genesis_doctype’ );

    do_action( ‘genesis_title’ );

    do_action( ‘genesis_meta’ );

    wp_head(); /** we need this for plugins **/

    ?>

    </head>

    I’ve never had issues with any other plugins giving me the error, didn’t know if it was an issue/big issue or what or if it was the reason why the Visual/HTML editor wasn’t working or what. Again, thanks so much.

  • crestfalleen
    • Flash Drive

    I tested the plugin on our test site and no problems with the editor. I also tested it on our main site in Safari (I was using Chrome) and I’m still having issues. I’ve uploaded another screenshot, without having it collapsed. It just doesn’t show the editor. Any clue what would do this? I need to get this up before I leave for the weekend and I’ve been working on it for 2 weeks. I am so close. Thanks.

    http://www.rgm.me/assets/RGM-popup-resize-2/screenshot2.png

  • crestfalleen
    • Flash Drive

    Awesome. I’ve added the condition for visit not via internal link and viewed less than 2 times, but it keeps coming up more than twice. Any ideas on that? I have to go out of the office for a bit, but I will check it later today/tonight. Again, that you so much for everything.

  • crestfalleen
    • Flash Drive

    Thanks for the update. I downloaded it and tried it and now I can’t get the popup to show again. Tried it with the conditions set to external links and less than 2 times, nothing. Cleared all conditions and nothing. And my cookies are showing nothing for a popup/popover or anything ‘pop’. I have it activated and set to only people who are logged in can see it at the moment, that doesn’t show anything either though. Thanks.

  • Barry
    • DEV MAN’s Mascot

    @crestfallen – can you pop up a couple of things for me?

    Firstly you wp-config.php file (please mask or remove the db access details before hand), then I can try logging in and comparing the cookie domains created with the settings in your config (can you send through the login details for that test site again please, I deleted the last ones as I don’t like to keep other peoples login details sitting on my laptop :slight_smile: )

  • crestfalleen
    • Flash Drive

    Thanks for the update. I downloaded it and have been trying it and I’m still not coming up with what is expected. I was wondering, is there a certain order that the conditions need to be in? I’ve been having different results in different browsers on different computers.

    I have the following conditions set up in this order:

    Visitor is logged in.

    Popover Shows Less Than “2” times

    Visit Not Via An Internal Link

    This is results I’m getting on our different computers and different browsers.

    On our PC laptop, using Google Chrome, I got nothing. No pop ups at all. Cookies isn’t even showing a popup.

    On our PC laptop, using IE8, it doesn’t show up at all.


    On my MacPro, using Google Chrome (which is what I usually edit the site in), the pop up will show up all the time on “Itinerary 2012,” “Patti’s Page,” and “Study Center” all the time, but not on any other page.

    On my MacPro, using Safari, it will show up all the time on the “Partner,” and “Study Center” page, but not on any other page at all.


    On my MacBook Pro, using Google Chrome it will always show up on “Patti’s Page,” “Partner,” and “Study Center” pages, but no other page ever. However, there is no cookies for a Pop Up or Pop Over or anything like that.

    On my MacBook Pro, using Firefox, nothing is coming up. Cookies however is showing “2.”

    On my MacBook Pro, using Safari, it comes up on the Home page every time, but not on any other page at all.

    Can you look and see if you are you getting the same thing there? Is it our site? If so, any suggestions on how to fix it? Is it the plugin? Any ideas? Thank you so very much.

  • Barry
    • DEV MAN’s Mascot

    You seem to be running wp-cache – just spotted the comment on the page source of your page – I think that is going to have some issues with the “don’t show more than” condition as when the site is serving a cached page it won’t be reading or setting cookies – will take a closer look.

  • crestfalleen
    • Flash Drive

    Downloaded it. I had “logged in” turned on so I could test it without anyone else seeing it. That’s the only reason for that though.

    Anyway, I downloaded it, but Getting similar issues though. On this computer, with “logged in” turned on, in Chrome, every time I visit the homepage it’s coming up. Changed it to “not logged in”, in Safari, nothing happened. On another computer, checked it in Chrome and Safari and nothing happened either.Is it my site or a plugin conflict? Anything that I can look into? Thanks so much guys. I know this has got to be as much as a pain to you as it is me.

  • crestfalleen
    • Flash Drive

    Thanks for info on that. I changed it, cleared my cache/cookies. On Safari on this computer, I’m getting it on the homepage every time i reload it/click back to it. On Chrome on this computer and on the other computer on Chrome and Safari I’m still getting nothing. Thanks.

  • Barry
    • DEV MAN’s Mascot

    Your cache is still affecting things.

    What you are getting is as follows:

    1. someone visits a page, they have seen the popover less than twice and are not logged in so page is built with popover and cached.

    2. anyone else who visits that page for the life of the cache will see that page with a popover on it regardless of the number of times they have seen the popover or if they have come from a internal link.

    1. alternatively, someone visits a page for the first time and they have seen a popover twice, or followed an internal link – they see the page without a pop over and it’s cached.

    2. For the length of time the cache of that page exists, no one will see a pop over on it because only the cached page is served.

  • crestfalleen
    • Flash Drive

    Barry,

    Thanks for all the help. Sorry it’s taken me so long to get back to you. I’ve had so much to do here. I’ve deleted the cache on the website. We’re using WP-Cache. I’ve also deleted the cookies for the browsers and this is what I’m getting: Chrome and Safari on one computer – The first page I go to it, the pop up is always loading on that page whenever I go back to it, but never on any other page. On another computer – it is always loading on a certain page, the partner page, but never anywhere else, and that was not the first page I went to. Do I need to delete something else? Thanks so much.

  • Barry
    • DEV MAN’s Mascot

    Hi – your pages are still being cached and served via the cache:

    <!– Dynamic Page Served (once) in 10.037 seconds –>

    <!– Cached page served by WP-Cache –>

    Until you disable wp-cache you are always going to have inconsistent showing of the pop-over as I mentioned in the earlier post

  • crestfalleen
    • Flash Drive

    I have disabled my wp-cache, deleted the cache first. Deleted cookies and I’m still having the same issue. It looks like it is caching 2 pages, even after I’ve set the conditions to be Popover shown less than 1. On another computer it’s just doing one page, but every time I refresh, click away and come back, it still loads the pop up. Thank for all your help so for. Besides the wp-cache, what else could it be?

  • crestfalleen
    • Flash Drive

    I’ve looked at the source and I see nothing at the bottom of the html. I may be missing it though. But I see nothing. I deactivated wp-cache a little over an hour ago. However, it’s still loading continually on the home page. Even if I go to a different page first on another computer (with cookies deleted). Is wp-cache still activated and I’m not seeing it, etc? Thank you so very much.

  • crestfalleen
    • Flash Drive

    Got on the live chat today and they told me what to remove and as far as I can tell, after removing those cache files, it works just like it’s supposed. Thank you so much for all your help and your endless research and work. There’s not enough I can say to express how awesome you guys are.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.