Pop-Up Premium not working

Hi,

I'm having a bit of trouble with the pop-up plugin... for some reason, I can't seem to get it to load on the homepage for the site. Is there a step I'm missing or have overlooked?

Any help is appreciated. :slight_smile:

Thanks,
A

  • Luís

    Hi Anthony ,

    Hope you're doing well today!

    I checked your website and you have some requirements to show the PopUp. However, I made some tests and I think the issue may be related to the "In a specific Country" option.

    Have you tried to test the "Country Lookup" in PopUp -> Settings, to see if it displays the proper location?

    I would like to suggest to try other option like "Free GEO IP".

    I hope this information has been helpful. If I can help you in this or other questions, please let me know!

    Cheers, Luís

  • Luís

    Hi Anthony ,

    Hope you're doing well today!

    As I mentioned in my previous reply, you are using some requirements, are you fulfilling all of them? The pop up will only show if:

    - was shown less than 3 times;
    - you are on a mobile device;
    - you come from a search engine;
    - you are in a specific country;
    - you are on a specific page (your homepage);

    All of these requirements needs to be fulfilling. I added Portugal to the included countries and I was able to check the pop up on your homepage.

    Maybe the popup was already shown more than 3 times, can you please try in a private window or using a different mobile device?

    Cheers, Luís