Pop Up Pro Compatible with 4.2.2?

Hi there,

I notice in the changelog that changes were made to the latest version of Pop Up Pro to make it compatible with 4.3, so just checking that the latest version will still work on 4.2.2? Or should I go for an earlier version?

Thanks