Pop Up pro & Layerslider not working on internet explorer

Hi, popup pro doesn't seem to work very well with internet explorer. I have used popup pro to create an overlaying layerslider animation. It works great on everything but internet explorer. All of them! 8, 9 and 10 are all showing a little grey square instead of the animation. There is a way to target phones but no way to target internet explorer.

I have tried if methods in my header with css to hide the pop up but no joy... thanks

  • Dann
    • Design Lord, Child of Thor

    Hi, I found a way around this,

    in css file:

    @media screen and (-ms-high-contrast: active), (-ms-high-contrast: none) {
    // HIDE YOUR POPUP's INDIVIUDAL CLASS HERE with display:none
    }

    ... and in header file:

    <!--[if IE]>
    <link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/css/ie.css" />
    <![endif]-->

    ... and add the display:none to that.

    It would be nice as a click on/off option though!

    : )

  • Michael Bissett
    • Recruit

    Hey @Dann, hope you're doing well today! :slight_smile:

    While I don't entirely follow what it was you were trying to do here (using popup pro to create an overlaying layerslider animation?), it's good to hear that you were able to come up with a fix here.

    Thanks for sharing what worked for you, and hope that the rest of your day goes well! :slight_smile:

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.