Popup cookies are not being stored in IE, firefox and Safari

Hey guys so I have Popup Pro installed on a clients site and the 1 day Popup cookies aren't being stored for IE, Firefox and Chrome. Here a link to the site. http://www.highridgefutures.com/managed-futures/ . All of the content under managed futures has the disclaimer popup enabled. If you need support access its already enabled. Thanks in advance.

  • Vinod Dalvi

    Hi Eric,

    I hope you are well today and thanks for posting on the forum.

    I could confirm on your site http://www.highridgefutures.com/managed-futures/ using Chrome browser that the pop up displays again and again even though i have clicked on the button "I HAVE READ AND AGREE TO THE STATEMENT ABOVE AND WISH TO PROCEED"

    You don't want to display it again on clicking the button, right?

    I want to know how you have implemented the pop up, would you mind if I logged in to your site and did some troubleshooting? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Kind Regards,
    Vinod Dalvi

  • Vinod Dalvi

    Hi Eric,

    Thank you for granting the support staff access.

    I checked the pop up content on your site and found you are displaying the button simply by using the following HTML code.

    <button class="memberagree">I HAVE READ AND AGREE TO THE STATEMENT ABOVE AND WISH TO PROCEED</button>

    Yes that is correct it should only display once, after the button has been clicked

    Have you developed any custom functionality to achieve this which is not working as it won't work by default like this without custom coding?

    Please advise.

    and the user agrees to the disclosure it shouldn't be shown till the following day.

    I am a bit confused here, in your above reply you said you wan to display the pop up once until the button is clicked so after that do you want to hide the pop up forever for the user or want to display it every day?

    Regards,
    Vinod Dalvi

  • Vinod Dalvi

    Hi Eric,

    The pop up option 'Close button acts as "Never see this message again" link' that you have used in your shared screenshot will make the pop up close button as shown in the attached screenshot act as "Never see this message again" link so that on clicking the pop up close button, the pop up will close and won't show until the next according to your configuration.

    I can see the pop up close button is working on your site as you are expecting. The custom button that you have added in the pop up content is not working like this because you have to develop custom code to make it work.

    The alternative way is to use the "Never see this message again" link in pop up by checking the option 'Add "Never see this message again" link' in the "Never see this message again" settings as displayed in the attached screenshot then just style this link as a button using CSS and change its text by translating it.

    Regards,
    Vinod Dalvi