Popup displayed on each scroll to bottom

Hi,
Hustle displays popup everytime I scroll to bottom of the page.
I close the popup on "x" or on "Don't show..." but as soon as I scroll again on the bottom, popup is displayed again.
I'm attaching popup settings screenshots.

  • Nastia

    Hello Nenad , I trust you are doing well today!

    Would you please run a quick test, can you replicate the same when all the other plugins are deactivated? There are some JS errors in the developer console, that indicates that there is a conflict with another plugin.

    Uncaught TypeError: a.data.split is not a functionxd_parser @ library.js:60xd_listener @ library.js:60(anonymous function)
    Failed to load resource: the server responded with a status of 404 ()

    Deactivate all other plugins, switch to a default WordPress theme and test if you can replicate this issue again. If everything is well, activate one plugin at a time to find the one that causes this.

    Follow the flowchart from our Getting Support manual:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    In case this issue persists, please grant access from WPMU DEV > Support so I can have a closer look?

    Please see the detailed instructions on the link below:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Let me know how it went!

    Cheers,
    Nastia

  • Nenad

    Hi,
    I corrected the javascript error - google tag manager didn't have any tags published so it returned 404.
    Now there are no javascript errors.
    When I re-moved all plugins but Hustle nothing was showing - only page header and footer. Popup didn't show.
    After I re-enabled all plugins page content and popup were showing.
    When page loads popup is shown each time I scroll to the bottom of the page - settings are after 20% of the page ( using incognito tab in Chrome, user not logged in ). Clicking on "x" and "Don't show..." closes popup - but on every scroll popup is shown again. If I refresh the page popup is not shown any more.
    In Chrome, when user is logged in, popup is not shown any more - I guess because "Don't show any more" was clicked.

  • Sajid

    Hello Nenad,
    Hope you are doing good today :slight_smile:

    I could get the similar behaviour on your website as well as on my own test site. But I think its not bug and instead its working the way it is designed.

    Also its not because of "Close button acts as 'Never see this message again' link" option. This is to check on page load, so once user will close, reload the page then this setting will be considered. Which is working as you confirm.

    If you don't enable this setting and setup with scroll, then it still display the popup each time you scroll that far in one session.

    However, if you wish I can move it into features and feedback section to add a setting to not show opt-in on scroll more than once per session.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

  • Sajid

    Hello Nenad,
    Hope you are doing good today :slight_smile:

    I have moved this thread to features and feedback section for consideration. Please bear in mind that by adding a request into features and feedback section does not guarantee that it will be added in the plugin for sure. It depends upon how much people are interested or effected with this issue and/or its possible to do add in a plugin with its current structure/framework.

    Thank you so much for taking time and bringing it to our attention and have a nice day :slight_smile:

    Best Regards,
    Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.