Popup Displaying Share Icons for the blog post

When adding "Share" buttons to my blog posts via the "Sharing" feature in Wordpress the Share buttons are displaying in the popup.

See attached screenshots. The desired state of the popup would to not have the share buttons from the post in the pop up.

  • Michael Bissett

    Hey @Andrew, hope you're doing well today! :slight_smile:

    Inside of your site's Dashboard, you'll need to go to:

    PopUp -> Settings

    And in the "PopUp Loading Method" section, set "Load PopUp using" to "WordPress AJAX". That's what got this working properly on my test site. :slight_smile:

    Let me know if this helps please!

    Kind Regards.
    Michael

    P.S. For anyone reading this later, the "Sharing" module referred to here is inside the Jetpack plugin.

  • Andrew

    So that worked however, I was using the "page footer" setting because using the Wordpress AJAX call would previously break the form embedded inside the popup. We use Hubspot's form which is essentially embedded javascript which we drop as code into the popup. When the "Wordpress AJAX" call is selected I saw the following behaviour:
    1. Visitor visits the site for the first time and sees the pop up with the form displayed. Visitor may or may not fill in the form.
    2. After some time, visitor revisits the site and sees the pop up but no form is displayed. Just a blank space.

    The embed code looks like this:

    <script charset="utf-8" src="//js.hsforms.net/forms/current.js"></script>
    <script>
    hbspt.forms.create({
        portalId: '449587',
    formId: '92ec9d26-5935-4340-abef-5dc48c57294e'
      });
    </script>

    If I switch to the "page footer" setting, the form displays reliably no matter how many times the visitor comes back but then I get the share buttons in the popup.

    Could the javascript be the issue? Any ideas? Have you seen similar behaviour with other embedded javascript in the pop up?

  • Michelle Shull

    Hey, Andrew!

    I have a workaround for you, so you can continue to use the page footer loading method, but hide the sharing icons from pop ups. Add the following to a custom CSS file:

    .wdpu-content .sharedaddy {
    	display: none;
    }

    Do you have a custom CSS plugin? If you've got Jetpack, it comes with one; some themes include a CSS editor, or you can get a plugin, like this one: https://wordpress.org/plugins/simple-custom-css/. Or, if you're using a child theme, you can just add this to the CSS file for your child theme.

    Would this work?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.