PopUP image http instead of https - causing insecure page content

Hello, the popup image that I have is not loading as https, so the web page is showing as insecure. How can i fix this?

https://morningside-inn.com/wedding-venue-in-frederick-md/
popup Version 4.8.0.0
wp 4.7.2

  • Sajid

    Hello Lesli Cochran,
    Hope you are doing good today :slight_smile:

    Yes, I can see this issue on your site but I could not replicate it on my own test site using the HTTPS though.

    I created a new popup, attached an image with that PopUp and enabled it. On front-end, I could not see any mixed content errors in console and further inspecting the code I see the URL is over HTTPS (see screenshot).

    It appears that you have switched from HTTP to HTTPS and the popup were created prior to migrating the site over HTTPS.

    If that's the case, then you have to do a search and replace operation on your site using the plugin like Better Search Replace.

    But before doing that, please first try using the SSL Insecure Content Fixer plugin.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support