Popup Pro Displaying on All Pages

With Popup Pro, my popup form is showing on every webpage a visitor visits, no matter if they competed the sign up form, clicked out of the popup window, or clicked the x to dismiss the popup. It continues to appear with every click through the site. It seems like the cookies may not be working or something. I've double checked and I do have cookies enabled and no browser add-ons at all, so that's not likely to be the issue.

I've had several reports of this from angry customers outside of my own testing, and I've personally been able to see the behavior on a Mac in Chrome and Safari, as well as on a completely separate desktop PC in Chrome and Firefox.

The popup form where this is happening is the 'Front Page: Not Logged In' form. It is currently inactive because I've had so many complaints. I enabled support access in the dashboard, so please feel free to activate it for your own testing; please just deactivate when finished until I can verify this isn't happening anymore.

    Nastia

    Hello tiffany, I hope you are doing well today!

    I can confirm this behavior on your site.

    Would you please run a quick check for a conflict with a plugin/theme?

    Deactivate all other plugins and test again. If the issue is gone, please activate one plugin at the time to find out which one is causing this conflict.

    Please follow the flowchart from our manual:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    You can create a staging site and run the test there. With Snapshot plugin you can restore your site in another installation.

    If the issue still persist, please enable WordPress debugging. To do this, please put the following code in to the wp-config.php file:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    After this enable the PopUp and logout form your website. Once the PopUp appears twice you candelete this code from the wp-config.php file.
    All the errors will be saved in a debug.log log file inside the /wp-content/ directory.

    Please attache the debug.log file here in this post.

    Let us know how it went!

    Cheers,
    Nastia