Popup Pro - Facebook Comments conflict - Disable checkbox not working

I am trying to solve an apparent conflict between Popup Pro and Facebook Comments.

Even though I have selected the "Disable Facebook Comments" checkbox, the popup displays a list of the facebook comments inside the popup.

Is there a bug where this checkbox does not work?

I have managed a sort of work-around to add custom CSS to "display:none" the list of comments, but the H3 element are still showing up.

I would like to supress the display of FB comments in the popup all-together.

Any advice would be apreciated...

here an example page, scroll down to the bottom to see this happening

  • Kasia Swiderska

    Hi Juergen,

    I've been able to replicate this issue on my testing site - I even tried to use Disable Comments plugin to see if that will help but with no success.

    It looks like the Facebook Comments plugin is not using the comments functions from WordPress, but simply appends it's comments to the content of the post using filter (that's why it is showing it on Popups).

    For now I'm not quite sure why the disable comments don't work with PopUps - I have to check with developer and check the code of the Facebook Comments.
    Is there a chance you report this also on Facebook Comments plugin support forum?

    Kind regards,
    Kasia

  • Juergen

    Hi Kasia

    Thanks for your help with this... I'll try to post it there too when I have a chance, but probably it would be better if this could be suppressed from the WPMU side without a dependency on FB comments to make changes to their plugin... I wished their entire deployment was wrapped in a div with a class, that way one could hide it with CSS...

    Is there a way for your plugin to ignore any content added to a (popup) post using a filter?

    Anyhow, let me know what ideas the developers have...

    Cheers, JB

    • Kasia Swiderska

      Hi Juergen,

      Because finding cause of this issue may take some time for developer, I'm attaching one file (class-frontend.php) for Facebook Comments plugin with really minor fix - wrap comments in one div with class "hide-this-fb-comments" - you can use it then like this

      .wdpu-content .hide-this-fb-comments {display: none;}

      This will hide comments in PopUp. I know this is workaround, but should do work until we figure something out.
      Unzip the archive, and overwrite file in Facebook Comments folder with new one by FTP.

      Kind regards,
      Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.