popup pro not saving any content in the popup

I have PopUp working on my staging site. Everything's the same as my live site.

On my live site I went to create a new PopUp. I copied the content of the test site into the new PopUp. I hit save. Nothing is saved.

I end up with empty content. A list of popups that don't have a name, have no content, and show nothing.

I disabled all plugins and this is still behaving this way. Attached screenshots of before, after, etc.

  • Michelle Shull

    Howdy, fox!

    Would you mind if I logged in to your site and did some testing? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access Tab

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here : https://premium.wpmudev.org/project/wpmu-dev-dashboard/ and then allow access as per the above process.

    Thanks!

  • fox

    I just did on a site set up in a folder of the main site, with all the same settings as the live site.

    If this helps. I ran with with debug on and got these errors in the log file when I attempted to create a popup:

    [30-Aug-2014 21:38:48 UTC] PHP Warning:  session_start(): Cannot send session cache limiter - headers already sent (output started at /(path to)/wp-includes/functions.php:3245) in /(path to)/wp-content/plugins/popover/inc/external/wpmu-lib/functions-wpmulib.php on line 73
    [30-Aug-2014 21:38:48 UTC] PHP Strict Standards:  Non-static method IncPopupRules::init() should not be called statically in /(path to)/wp-content/plugins/popover/inc/class-popup-rule.php on line 198
    [30-Aug-2014 21:38:48 UTC] PHP Strict Standards:  call_user_func_array() expects parameter 1 to be a valid callback, non-static method IncPopup::load_optional_files() should not be called statically in /(path to)/wp-includes/plugin.php on line 470
    [30-Aug-2014 21:38:48 UTC] PHP Strict Standards:  Non-static method IncPopupDatabase::get_settings() should not be called statically in /(path to)/wp-content/plugins/popover/inc/class-popup-base.php on line 220
    [30-Aug-2014 21:38:48 UTC] PHP Strict Standards:  Non-static method IncPopupBase::get_rules() should not be called statically in /(path to)/wp-content/plugins/popover/inc/class-popup-base.php on line 227
    [30-Aug-2014 21:38:48 UTC] PHP Strict Standards:  Non-static method IncPopupDatabase::get() should not be called statically in /(path to)/wp-content/plugins/popover/inc/class-popup-admin.php on line 1028
    [30-Aug-2014 21:38:48 UTC] PHP Strict Standards:  Non-static method IncPopupDatabase::get() should not be called statically in /(path to)/wp-content/plugins/popover/inc/class-popup-admin.php on line 831
    [30-Aug-2014 21:38:48 UTC] PHP Strict Standards:  Non-static method IncPopupDatabase::get() should not be called statically in /(path to)/wp-content/plugins/popover/inc/class-popup-admin.php on line 949
    [30-Aug-2014 21:38:48 UTC] PHP Strict Standards:  Non-static method IncPopupDatabase::get() should not be called statically in /(path to)/wp-content/plugins/popover/inc/class-popup-admin.php on line 993
    [30-Aug-2014 21:38:48 UTC] PHP Strict Standards:  Non-static method IncPopupDatabase::get() should not be called statically in /(path to)/wp-content/plugins/popover/inc/class-popup-admin.php on line 1004
  • fox

    Also, I went to phpMyAdmin to see if it's saving to the database and it is. It saves the post and the post meta.

    Since the plugin was completely redone since the last time I used it, I also went back and installed the previous version. I then upgraded to the current version. I received this warning on upgrade and activation:

    Warning: Creating default object from empty value in /(path to)/wp-content/plugins/popover/inc/class-popup-item.php on line 340

    It pulled up an old popup I had. I can't change it. I still can't add any new popups. Not sure if anyone is noticing this on a Sunday. This would be nice to resolve as quickly as possible. I've given access to my admin for this.

  • Michelle Shull

    Hi there, Fox!

    I tried to log in to your site through support access, and I think I may have accidentally found the issue, and it's to do with redirects.

    I'm unable to use support access to log in, so I'm going to send you to the contact form so you can contact me directly. I'm currently almost to the end of my shift, but I'll be in early tomorrow.

    Use this to get your message right to me:
    Subject: "Attn: Michelle Shull"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    Thanks!

  • Michelle Shull

    Hi, fox, sorry for the delay here.

    I've tested your site, and tested on my site, trying to replicate your site, and while it's easily reproducible on your site, it's not happening on either of my sites I tested on (one on VPN, one on a managed WP host.)

    If there were no changes beyond upgrading the new version of this plugin, and, as you said in a different thread, you've tried it with a default theme and with plugins temporarily disabled, the next step is to call in Second Level Support, which I'm flagging.

    Thanks so much for your patience, I see a member in this thread is facing the same issue: https://premium.wpmudev.org/forums/topic/popup-pro-saving-blank-popups-no-data-or-settings-are-saved

    Take care

  • Tyler Postle

    Hey Fox,

    I noticed that Michelle has already flagged SLS, so we will get their valuable feedback soon :slight_smile:

    In the meantime, I am wondering if your host might have an aggressive caching setup on their server side. Or if you have caching plugins activated then just double check to deactivated them then clear your browser cache and everything then test it out.

    Have you already done that? I just want to get this narrowed done as much as possible so we can get resolved asap for you. Thanks for all your patience!

    All the best,
    Tyler

    PS. There is also a new version of Pop Ups out now you can upgrade to 4.6.1.1

  • Hoang Ngo

    HI @fox,@DavidM

    I hope you are well today and I'm sorry for the delay.
    After debugging, I have found that the ACF plugin have some conflict to the popover. When the popover form submitted, ACF take over the save process, so at that stage, the popover still not handler it content yet.

    Does it fine if I upgrade the ACF to newest version, also have a quick disable that plugin just for testing purpose ?

    Please advise,
    Thanks!!!.

    Best regards,
    Hoang Ngo

  • fox

    I am not on WPEngine. I use Siteground and do have their SuperCacher enabled (http://www.siteground.com/tutorials/supercacher/supercacher_intro.htm).

    I also use Cloudflare (I pay for Cloudflare) and have their cache enabled but NOT on my wp-admin pages.

    However, I'm running into the same issue on my staging site now which does NOT have caching enabled.

    I'm not disabling the cache on my entire site for this plugin to work. I've already coded an exit popup for the site. I'd like to have the plugin working for the other uses it offers though and save myself issues.

  • Philipp Stracker

    Hi @Fox,

    I think I have found the solution to your issue!
    Using the Login details you already sent to Michelle some days ago I installed a beta version of the next release of the PopUp plugin and tested it:
    Yay! It works :slight_smile:

    I suspect your server is using some kind of php-memcache extension to cache data. This caching is not related to WordPress but is done on a lower level by the server to preserve data between requests.
    To optimize PopUp loading we instruct WordPress to cache them (it reduces database access and speeds up page loading time). Obviously WordPress will utilize the PHP memcache layer to preserve PopUp data.
    So the solution was to simply tell WordPress to renew the Cache after a PopUp was saved. All changes that I made were saved correctly and instantly.

    Please also review if the issue is resolved for you by creating some "real" PopUps for your site. Let us know if everything works or you need some assistance with anything!

    If everything is fine I advice you to remove the FTP user/WordPress user that you created for us (or change the password) ... just to be sure :wink:

    Thanks, Philipp

  • fox

    Yes, they do have memcache enabled on the site, along with Varnish static and dynamic cache.

    I copied the beta plugin over to my staging site and activated. All my Enhanced Text Widgets widgets were gone (https://wordpress.org/plugins/enhanced-text-widget/). They were there yesterday when doing work on my this staging site and I didn't delete them.

    The popups are saving correctly and working on the staging site.

    I did try changing the settings to load in the page footer or via Wordpress AJAX and it wouldn't change the settings from Custom AJAX.

    I'm nervous about loading on the live site yet. And I'll keep playing to find any other bugs on the staging site. I'm eager to have a final update.

  • Philipp Stracker

    Hi @Fox,

    thanks for trying the updated plugin and your reply!
    I am very certain that replacing the plugin files did not cause the enhanced text widgets to disappear - replacing the plugin files will not change anything in the database.

    How did you transfer the data to the staging site? Maybe you have used a tool or plugin that has overwritten some values in the wp_options table or you have changed the theme which could render existing sidebars and widgets inactive...

    I can recommend these 2 steps to have more confidence in the upgrade :wink:

    1. Backup the live site directly before updating. Use our Snapshot plugin or other plugins like BackWPUp
    In case something goes wrong you can usually restore the page in a matter of a few minutes. If you never restored a backup I suggest that you try to make a new backup of the staging site and restore it, just to get a hang of it

    2. Create a fresh staging site using our new plugin Cloner! This will create a new WordPress site using native WordPress functions, which has the same effect as entering the data via the admin interface (the database will be consitstent)

    Also you mentioned an issue with the PopUp settings... Since your site is using several caching methods I suggest you stick with the default loading method "WordPress AJAX", since this is the most cache-friendly version available.
    Can you change the Loading Method to "WordPress AJAX" or does it not work at all? If it does not work:
    - Can you change any other settings on the Settings page?
    - Is this problem on the live site or on staging, or both?

    Thanks for your patience and for helping us improve our plugin :slight_smile:
    Philipp

  • Philipp Stracker

    Hey @Fox,

    we just released a new version of the PopUp Pro plugin (4.6.1.2) that has some improvements for servers that use some more aggressive caching.
    Can you please have a look if this plugin is working for you?

    If you still have problems then drop me a line and I will check your server again (using the login details you sent us on Sep-1; if the problem is on a different server then please send us the new login details same as before)

    Thanks, Philipp

  • Tyler Postle

    hey Fox,

    Hope you're doing well today and thanks for bringing this up!

    Are you referring to the "Deactivate" link when you hover over the popUp name in the list? Screenshot attached.

    I tested that out and then went to "edit" and the PopUp showed as "Inactive" It also stopped showing up on the frontend as well.

    Are you still able to reproduce the issue now?

    Look forward to hearing back.

    All the best,
    Tyler

  • Tyler Postle

    Hey Bess,

    Hope you're doing well today!

    Would you mind posting that in a new question? You can always link back here for reference :slight_smile: it will just keep it more organized and easier for us to follow that way as this thread is already quite long.

    You can ask a new question here: https://premium.wpmudev.org/forums/#question

    Also, if you could grant support access at the same time too then that will usually speed up the troubleshooting process :slight_smile:

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    All the best,
    Tyler