popup pro not showing on homepage of test site

test site: advizrz
we are using a popup that we only want to show on the homepage.

does a site have to be live for the homepage popup to work? if so did something change since it was working when On specific URL turn on and specific URL cambridgesourcesites.com/advizrz/. but as of last thursday afternoon it know longer opens.
can get it to open on the contact page using the specific URL cambridgesourcesites.com/advizrz/contact/

    Rupok

    Hi cambridgesource,

    So sorry for the inconvenience you are having. This is really weird and should not happen. I just tried to regenerate this on my test site but I could not. When I set my site homepage URL in the "On Specific URL" condition, PopUp shows fine in my homepage. So I think, this is your site specific issue.

    Just to make sure no other plugin is causing this, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Can you also check in your browser console for any errors on your homepage? If you see any error there, can you please copy those and paste here? That will give us valuable insight regarding the issue.

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know the result of your test and confirm here when you are done granting Support Access. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok