Possible problem with WP Smush PRO

Good morning.
We have several images that don't appear to be smushing. Do I maybe have an incorrect setting? Image details attached.
Thanks.

  • Rupok

    Hi Robert,

    So sorry for the inconvenience. From your screenshot, it seems like that image is too big in resolution. Can you please try resizing the image from Edit Image option in your media gallery? A full HD display resolution is 1920 X 1080 px. So having an image such large in dimension is not really necessary to make it look sharp. It will only increase your site load time and kill your server bandwidth. If you are showing that image in a 800 X 1200 px frame, then resizing that image to 800 X 1200 px will show that image sharp on all screens. And that will also drastically decrease your file size.

    So can you please try resizing those images and then super-smushing them with WP Smush Pro? I believe, it will give you best result.

    To check the WP Smush Settings on your site, I tried to login to your server with Support Access. But it's showing me this:

    Most probably Wordfence Security is restricting access to your site from Bangladesh. Can you please fix this so I can have a look on your Smush configuration and guide you better?

    Please confirm here when you are done. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Nithin

    Hi Robert,

    Hope you are doing good today. :slight_smile:

    Smush Pro has a limit for 32MB size of images, however it should be able to smush images with bigger dimensions without any issues, but as mentioned images with such large dimensions isn't required, and would recommend you to follow what Rupok has mentioned.

    I checked your website, and performed bulk smush, and it seems like the plugin does seem to work fine, by default WP Smush Pro will take your original image, and compresses the images into 5 thumbnail sizes as seen in the screenshot. The plugin won't smush the original image size, until you enable Include my original full-size images option under, Media > WP Smush. You can also enable super smush my images option, if you think it's required.

    You just have to click the Bulk Smush Now button, so that it starts to smush the next batch of images.

    I hope this helps, please advise if I'm missing anything, so that we could give a closer look, if needed. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.