[Post Indexer] PHP notices in logs

I'm getting the following in my logs

[03-Dec-2018 01:20:26 UTC] PHP Notice: like_escape is <strong>deprecated</strong> since version 4.0.0! Use wpdb::esc_like() instead. in /Users/trasiah/www/sites/iadnew2/public/wp-includes/functions.php on line 3853

I would just like to confirm whether this is coming from Post Indexer & if so, if it can be added to the next release. Thank you!