Post Indexer Problem

I have Post Indexer installed on our staging server. We are hosted by WP Engine. I'm seeing two issues.

1) The Post Indexer will not run unless I disable alternate cron. I don't want to disable alternate cron in our production environment. Is there a way to run Post Indexer on alternate cron?

2) When Post Indexer runs, it appears to run successfully on the first pass, but the second pass I get an error. See screenshot.

Fatal error: Call to private method ProcessLocker::is_locked() from context 'postindexeradmin' in /nas/content/staging/citymomsblog2/wp-content/plugins/post-indexer/classes/class.postindexeradmin.php on line 1027

  • Denitsa

    Hello Stephanie,
    I hope you are having a fantastic day!

    So I'm guessing you have define( 'ALTERNATE_WP_CRON', true );in your wp-config.php? There shouldn't be an issue between the plugin and alternate cron usually.

    I'd like to have a look at the WP debug log, so could you please access your server through FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);

    and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    The log will be saved to a debug.log file inside the "/wp-content" folder. Please save the file as a .txt and attach it to your next post.
    If the file's larger than 5MB you might need to upload it somewhere like Dropbox and share the link here.

    While you're there, can you also append the following to the wp-config.php?

    define( 'WP_MEMORY_LIMIT', '512M' );
    define( 'WP_MAX_MEMORY_LIMIT', '512M' );

    Let me know how it goes!

    All the best,
    Denitsa