Post Page and Front/Home Page Not Working

I would like the Posts to show up in the Community Page, instead of the Homepage. So I went Dashboard --> Settings --> Reading and changed it so that the Front Page should be the default and the Post page is Community (see screen shot).

But when I go to the Community Page (http://wholehealthathletics.com/community/), the posts don't show. (What you see under "What's New" in the screenshot is the Status Plugin.) You will also notice than on the Community Page, all three Home Sidebars show up PLUS the Left Member Sidebar.

When I go to the Homepage (http://wholehealthathletics.com/), everything looks good except that in the Window Tab, it has the same title as the community page: "Community | Whole Health Athletics". (see screenshot).

Also notice that under Appearance --> Theme Options --> Gallery Settings I have disabled the Homepage featured Block. (see screenshot)

Finally, I created the Home page in the menu by using the "Custom Links" tool. (see screenshot)

How to I get the Posts working right and the Tabs displaying correctly?

  • Arun Basil Lal

    Hello jtres,

    I am sorry, but am a little confused with the questions, so if I am not with you on any of my answer, please forgive me.

    But when I go to the Community Page (http://wholehealthathletics.com/community/), the posts don't show. (What you see under "What's New" in the screenshot is the Status Plugin.) You will also notice than on the Community Page, all three Home Sidebars show up PLUS the Left Member Sidebar.

    I assume that the community page is a new Page you create with the Blog and News template. yes? Do not set it as Posts Page on Reading Settings, revert your reading settings back to defaults, the Posts Page should read --Select-- and you will have your posts showing up on the Community page. See the screenshot attached.

    When I go to the Homepage (http://wholehealthathletics.com/), everything looks good except that in the Window Tab, it has the same title as the community page: "Community | Whole Health Athletics". (see screenshot).

    Please create a new Page and Set it as the Home Page in your reading settings. To set the title, you might want to use an SEO plugin, like the Infinite SEO plugin, with which you can set these titles easily. https://premium.wpmudev.org/project/wpmu-dev-seo

    See the screenshot attached.

    Also notice that under Appearance --> Theme Options --> Gallery Settings I have disabled the Homepage featured Block. (see screenshot)

    This is strange, you shouldn't be seeing the gallery at all. Do you want to remove it? I could give you other options.

    Finally, I created the Home page in the menu by using the "Custom Links" tool. (see screenshot)
    How to I get the Posts working right and the Tabs displaying correctly?

    I assume you mean the Custom Menus based on the screenshots. What are you trying to do here? Isn't it working the way it should work?

    Please answer my questions so that I can help you further :slight_smile:

  • jtres

    Hi Arun,

    Thank you for your reply!

    I assume that the community page is a new Page you create with the Blog and News template. yes? Do not set it as Posts Page on Reading Settings, revert your reading settings back to defaults, the Posts Page should read --Select-- and you will have your posts showing up on the Community page. See the screenshot attached.

    Oh my goodness! I feel like such a dummy. That's what the problem was! I didn't set the Template for the Community page... it was on "Default Template".. And, actually, that seems to have fixed all my other issues!

    Oh, the simple things...

    Can't thank you enough!

    Jenn

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.