Post page are not hidden for visitors after updating Membership Pro

Hi
I have a "page" on my site which use the Genesis page template called "Archive".
This page is set as my post page in Wordpress settings.

After I updated to latest Membership Pro version this page is not hidden for visitors anymore the right way... It dont show my Protected content page.
See attached screenshot.

I already talked to the WPMU billing support, who told me to use this forum for support and then just refer to my ticket where you can find the site url.
Ticket id: ?ticket=89821290/238878

  • Patrick
    • Support Monkey

    Hi there @Anders

    Welcome to WPMU DEV, glad to have you aboard!

    I found your email with the URLs to your sites. I just checked the live site and see that you are using Membership version 3.5.1.6 there. There have been a few changes to various redirect rules since then.

    First thing though; do other protected pages/posts etc correctly redirect to your "protected" page when unauthorized users try to access them? In other words, is this issue only occurring on that one page?

    If it happens on all content, please ensure that Membership protection is enabled. You can do that from either the main Membership page in your admin, or from the toolbar switch (screenshots below).

  • Vinod Dalvi
    • WP Unicorn

    Hi @Anders,

    I didn't find your email so could you please share the page URL again here by masking your site domain so that i can check it.

    Also would you mind if I logged in to your site and did some troubleshooting? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Regards,
    Vinod Dalvi

  • Patrick
    • Support Monkey

    Hi again @Anders

    I hope you're well today!

    Sorry I wasn't clear in my first reply above.

    I had viewed both sites and was mentioning the possibility that perhaps differences between the older version you're using on your live site, and the most recent one used on your development site, were the reason for this issue.

    As it turns out, that is exactly the case here. I logged into your site and found the problem:

    The protection logic for the homepage (and static page for blog archives if used) has changed. There is now a checkbox under the Configuration tab that can be checked to apply protection rules to the homepage. That rule also applies to the blog archive page if a static page is selected for it under Settings > Reading.

    I have checked that box on your dev site, and have ensured that the page you have selected for your homepage (under Settings > Reading) is accessible to your Visitors level, but the Blog Archive page is not accessible to visitors.

    Now when a not-logged-in visitor tries to access the blog archives, they are correctly redirected to your protected page with your subscription plans on it.

    Please do let us know if this helps, and don't hesitate to post again if you need more help with this.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.