Post Page to FB disabled, yet posting pages is possible

Hi,

For all our blogs, I have disabled the "Autopost Pages to" by selecting the "Don't post this type to Facebook" option.

However, when I open up a random page on any of the blogs in our multisite environment, I notice that the Autopost to facebook section is there and actually posts Pages to FB. Is there something wrong with my settings or is this a bug?

Hoping you can help me out!

Regards,
Rinck

  • Michelle Shull

    Hi, Rinck!

    The checkbox next to the autopost option on the edit page screen should be unchecked by default, is that the case for you, as well?

    That option is available in case you'd need to override your default autopost setting for a particular page or post. If you'd like it not to show at all, check the box next to "Do not allow individual posts to Facebook" in Facebook > Settings via your WP admin area.

    Hope this helps!

  • Bart

    That creates a new problem, namely that I can no longer edit a FB post title before autoposting; it will always use the WP post title.

    How I would like to see it work:
    * For most of my blogs, always autopost and do not allow users to disable autopost (using the "Allow users to skip autopost"-option); this only applies to posts of type "Posts"
    * Allow users to change the FB post title if they want, if not use the WP post title (requires meta box)
    * Do not allow users to post any other post type to FB (autoposting is disabled for these other post types, but appearantly users can still post to FB manually for these post types).

    Is this possible? If so, how?

    Looking forward to your reply!

    Regards,
    Rinck

  • Michelle Shull

    Hey, Rinck!

    The trick here is to turn on Facebook Open Graph. This will give you an additional metabox (And it shows even if autoposting is disabled) that allows you to change the title to something different than the WordPress title.

    I don't believe you can prevent users from posting what they want to Facebook, is that what you mean when you say they're posting manually?

    For question #1, if you've got Ultimate Facebook network activated, you'll need to go into the Network Admin dashboard to allow sites to override the network defaults. That's covered in the first part of our usage guide, here: https://premium.wpmudev.org/project/ultimate-facebook/#product-usage

    Hope this helps!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.