Post showing text on back end when published, front end not showing anything.

Hello,

It seems that when I make a new post, for some reason none of the text or media will show through when published. In the back end of the published post, I can see the text but on the post itself it does not show. The website and page is: http://shepherdhelp.org/available-for-adoption/ . The top two listings Bell and Joe show what I’m talking about. On the listing page you can even see the text, but on the post itself nothing shows.

What’s weird is on the ‘Joe’ page, the title is showing lower case when really it is capitalized. Also, I have a social media plugin that automatically inputs a social media bar at the bottom of posts. You can see what I mean by viewing any other post on the website. It appears that these new posts are not calling the plugin either.

Does anyone know what this may be caused by? My host checked server logs and they claim to be clear on their end.

Thank you!

  • ehoanshelt
    • Flash Drive

    Hey!

    Without looking at your backend, their isn’t really much I can do to provide help but I have found something that might lead you in the right direction.

    So looking at the rendered pages, I see your issue. Looking at http://shepherdhelp.org/joe/, I’m seeing this as a “Page” and not a “Post”. You can see this by looking at the HTML and viewing the body classes. I see this:

    <body class="attachment page page-id-3229 page-template-default gecko">

    This tells me that you have a attachment page linked here. The other pages that are working are showing as posts. Here is the body class for http://shepherdhelp.org/milly-and-victoria/ :

    <body class="single single-post postid-3173 single-format-standard gecko">

    So some things to check:

    1. Did you create a post or did you create a page?

    2. If you created a post, do you have any special post format selected?

    I hope this helps!

  • WebSeedsSolutions
    • New Recruit

    Hey! Thank you for responding so soon. :slight_smile:

    I did in fact create a post for those two, just as all of the others. That is very odd that they are rendering as pages. There is no special post format, nothing different than any other time.

    I am going to try to mess with the plugins to see if there is a bug with one of them, though I doubt it. :

  • WebSeedsSolutions
    • New Recruit

    This is weird. I tried creating a new post from a different account, and it worked. The same exact info. BUT, when I went to change the slug from ‘joe-3’ (from creating a few pages to test) to just ‘joe’ after deleting the original, it reverted back to the problem now. However, when I change it again back to joe-3 or anything else, it is still coming up errored. Somehow the slugs and permalinks are affected, but at the same time they are not. This doesn’t make sense!

  • WebSeedsSolutions
    • New Recruit

    It seems that creating a post with the name Joe, and the slug Joe, is creating this issue… I don’t understand.

    The same post that wasn’t working, I changed the name to ‘Frank’ and the slug to ‘frank’, and now it works.

    Any idea why ‘Joe’ isn’t working?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.