Posting on the newsfeed takes a lot of time

Posting on the newsfeed takes a lot of time. How do I fix that?

  • Bojan Radonic
    • Head of Support

    Hey there @anassabri,

    Hope you're well today :slight_smile:

    Can you please add more information on where exactly is this happening and possibly provide temporary admin access via our Dashboard plugin so I can take a look?

    You'll find more information on how to do that by following this link: https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Looking forward for your response :slight_smile:

    Cheers,
    Bojan

  • anassabri
    • Flash Drive

    Hi Bojan,

    Thank you for your quick response. I gave you the access. I have been using the WPMU Status Plugin on the main site asabri.co to post activity on the newsfeed. You can see it when logged in. For some reason the status bar is not showing up even if it is activated and I have selected it to show up on main page from the settings. so sorry, but this is another issue to look into. But the original issue I asked was if you post anything using the status bar of the status plugin, it takes a long time (3-4 seconds) for it to show up on the newsfeed. Can this posting time lag be reduced ? Comparing to facebook, Im sure sure their code is highly optimized for this. Thank you for looking into this.

    Anas

  • Bojan Radonic
    • Head of Support

    Hey again Anas,

    The reason for this is because each time you update status, the page is being reloaded and your page load time is couple of seconds. So working on your site load speed should be able to improve this as well. There is a great blog post on the topic that you can check here.

    Regarding Status not being displayed on the main page, I can see it there without any issue, did you managed to fix that or am I missing something?

    Please advise,
    Bojan

  • anassabri
    • Flash Drive

    Hi Bojan,

    "The reason for this is ecause each time you update status, the page is being reloaded and your page load time is couple of seconds." The default post box posts right away so I guess the code for status plugin needs to be optimized.

    Yes, in settings for status plugin I chose display on all pages so its showing. But when I select show only on front page then it does not show. I want it to show for front page only (which has newsfeed).

    Thank you

  • Bojan Radonic
    • Head of Support

    Hey again Anas,

    I apologize for the delay :slight_frown:

    I've tested "Show on front page only" option on my sandbox site and everything worked properly. Could you please re grant admin access so I can take a look?

    Regarding it being slower then standard post I'll pass the info to our developer so he'll take a look and possibly try to optimize it in the future.

    Best regards,
    Bojan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.