Press buttons on subsites and get redirected to https!

Hello,

My site https://forenigo.dk as you can see, is with https - SSL. But I chosed to run my multi/subsites without, and then customers can by their own domain and add ssl if they want to.

But I have a problem: When a customer enters his site and press a button (examble to "about us" page), he get redirected to enter the page with https. Then he can't see the site because the browser won't allow it. It says insecure content and so on. What is wrong? The frontpage work without https, but when you wanna enter another part of the site, you are kind of forced.

Try yourself with http://cafeen.forenigo.dk/

Have I enabled https wrong on my own site?
I just:
- Pressed a button on my webhotel, so that ssl/https works on my site
- Then went to mySQL (phpMyAdmin) and edited the wp_options so my url is with https instead of http
- Then added this to my .htacces file:
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://forenigo.dk/$1 [R,L]
</IfModule>

Is there something wrong?
- And I have NOT marked the two "force ssl" options in the Domain Mapping plugin.

Please help me, before I get insane trolling around with this :wink:

Best regards
Nicolaj

  • Adam Czajczyk

    Hello Nicolaj,

    I hope you're well today and thank you for your question!

    When the main site is set configured to use https (hence the "they changed wp_options" part), sub-sites that you create should also follow that pattern and get https configured in Site URL. Please try the following:

    - as a super-admin go to "Network Admin -> Sites -> All sites"
    - find the "cafeen.forenigo.dk" site on the list and hit "Edit" link
    - you should see a "Site URL" there that starts with "https://" so edit it and change to "http://"

    After that please check the site and see if all the URLs work fine. That should confirm the case and if it solves the issue you might want to make that change to other sites.

    Alternatively, since you are using Domain Mapping, you might try checking "Force http" in "Would you like to force http:disappointed:https in front-end pages".

    Let me know about results, please.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.