PrettyPlugin upload screenshots folder not working

Hello,

I can't get Auto Load Screenshot With Correct Name working.
I have the folder wp-content/uploads/prettyplugins/screenshots
And akismet-akismet.png is in there (and akismet is installed).
I still get the default image.

Autoloading the screenshot images from the plugin folders works fine.

Thanks in advance!
-Sandor

  • Sajid

    Hello Sandor,
    Hope you are doing good today :slight_smile:

    I could not replicate this issue on my own test MultiSites. Auto Load Screenshot With Correct Name is loading the screenshot I added in wp-content/uploads/prettyplugins/screenshots. I also tested with akismet plugin and the image name is akismet-akismet.png.

    Please make sure the name of screenshot does not have any spaces or dashes in it.

    If still don't work then run a plugin theme conflict test by following this easy troubleshooting flow chart.

    This is basic test that is necessary to perform to determine whether the issue is with plugin itself or there is a conflict.

    Once done and still issue persists then please enable support staff access so I could take a closer look.

    To grant access go to Dashboard -> WPMU DEV -> Support -> Support Access -> Grant Support Access or see this manual for more details regarding how to enable support staff access.

    Take care and have a nice Sunday :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

  • Sandor

    Hi Sajid,

    Followed the chart and still have the issue.

    I installed prettyplugins on another wpmu install on the same server - deactivated everything except the wpmudev dashboard and prettyP, and enabled only the 2017 theme.

    I added an akismet-akismet.png file to the magic directory and still nothing.

    I opened support on the site I'm using for testing. I'm not sure if you can see which of my sites have support open..

    It's still Saturday here :slight_smile:

    Thanks!
    -Sandor

  • Sajid

    Hello Sandor :slight_smile:

    I can see the support staff access open for one of your site. But to further investigate this issue, I need FTP and WordPress login details directly.

    You can send the requested details via our secure contact form in following format.

    Subject: "Attn: Sajid Javed”
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference

    Take care and have a nice day!

    Best Regards,
    Sajid - WPMU DEV Support

  • Sajid

    Hello Sandor,
    Hope you are doing good today :slight_smile:

    Thanks for sending in FTP and WordPress admin details directly. I tried to further troubleshoot this issue but it did not worked any way on your site. However, me and one of my colleague still unable to replicate it on our own WordPress MultiSites setup.

    That means, there is something wrong on your server. I am flagging SLS support staff here so we could further investigate this issue. Please note that they will try their best to get back to you but their response time can be slower due their nature of job. So please be patient.

    Take care and have a nice day!

    Best Regards,
    Sajid - WPMU DEV Support

  • Ivan

    Hi Sandor !

    It happens because your site uses different uploads folder for subsites. I copied (wordpress_folder)/wp-content/uploads/wp-content/uploads/prettyplugins folder to (wordpress_folder)/wp-content/blogs.dir/2/files folder and it works fine for 'acuclinic' subsite now. I think, unfortunately, now there is no better workaround for it. I think we will fix it soon. :slight_smile:

    Best regards,
    Ivan.

  • Sandor

    I'm confused,

    Are you saying that a vanilla install of wpmu puts all the files from all the subsites into one folder?
    And that the path you found was somehow updated programmatically(by a theme or plugin)?

    I don't think I've ever seen that, and the wordpress codex indicates that separate folders are standard. I had all other plugins and themes disabled (and I don't believe any changed the upload path even when active).

    Thanks,
    -Sandor

  • Ivan

    Hi Sandor!

    By default wordpress Multisite uses /wp-conten/uploads/ folder for main site, /wp-content/uploads/sites/2 for first subsite, /wp-content/uploads/sites/3 for second subsite, etc.
    Your site uses /wp-content/blogs.dir/2/files for first subsite. It means that some code of plugin or theme changes the uploads folders. I can look which plugin or theme do it but now your site is unavailable.

    Best regards,
    Ivan.

  • Ivan

    Hi Sandor !

    Actually - blogs.dir was the default for wpmu and was changed to 'sites' around 3.5..

    You are right! I didn't know about it. :slight_smile:

    Do you use this feature on your own production networks?

    If you mean "this feature" - Pretty Plugins with "Auto Load Screenshot With Correct Name" option - I think that no because it would not work for us too, although I do not have access to such information :slight_smile:

    If you can't wait for new version of the plugin with fix for this. You can try to replace this block of code in file (wordpress_folder)/wp-content/plugins/pretty-plugins/pretty-plugins.php (approximately 109th line)

    To this code

    if($this->blog_id != 1) {
        switch_to_blog( 1 );
        $wp_upload_dir = wp_upload_dir();
        restore_current_blog();
    }

    Attention: we don't recommend you edit the code of any plugin, it's very specific situation. Also, don't remember that after update of this plugin this changes will be lost.

    Best regards,
    Ivan.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.