Preview option doesn't work for custom post types

We have a custom type "Shows". When editing, the preview button doesn't work. The "view post" button on top works fine.
We have a custom type "Shows". When editing, the preview button doesn't work.
I've tried to re-save Permalinks settings, tried to deactivate Domain Mapping, but this didn't help.
I will also do a plugin/theme conflict test after hours.

  • Kasia Swiderska
    • Support nomad

    Hello Ralph,

    I'm sorry to hear about this issue.

    I have to escalate this our Second Line Support Developers to check that closer as I wasn't able to find why it's working sometimes and sometimes not (I checked newly created custom post and it worked then).
    They will investiagte this and let you know what is causing this problem.

    kind regards,
    Kasia

  • Konstantinos Xenos
    • Rubber Duck Debugger

    Ralph ,

    Unfortunately I couldn't replicate this on my test sites. I also see that the issue happens on preview links from 'already' existing posts only, so while creating new ones that aren't published yet the Preview works as expected.

    Have you managed to make a conflict test? I see that the posts are also not using Gutenberg editor but I couldn't see any related plugins that are hiding it either, could you tell me if there's something extra like a mu-plugin preventing Gutenberg to load ? Maybe there's a conflict on that area that we could investigate.

    I could make a conflict test for you as well but I had to inform you first and get your permission as the website won't be functioning properly until the test is finished since I'll be deactivating plugins and themes to see if there's a conflict there.

    Regards,
    Konstantinos

        • Konstantinos Xenos
          • Rubber Duck Debugger

          Ralph ,

          If possible could you please disable the support for Post Formats for your CPT?

          After a lot of testing I've found out that this is most likely the cause for the 404 errors since. We're looking into it as it might be a conflict but until further notice if you aren't actually using the formats it'd be best to disable them for the CPT so you can have your previews working again. I've informed our Developers on all of my findings so they can work for a permanent solution but I unfortunately I don't have an ETA at the moment.

          Regards,
          Konstantinos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.