Preview result 404 BUT VIEW Page displays page

Hi Support-Team,

unfortunately we can't figure out, why

Preview results is 404 error

BUT

VIEW Page displays the page. Attached below screenshot.

NOTE:
CustomPress is activated on aboutme.bestof.... sub domain
Acutually settings are only done for Self-Introduction (My Turn) page and posts to get familiar with this amazing WPMU Dev plugin.

Support Access is granted.

We appreciate if one of you expert can help to sort this out.
Thank you.
Prinz

  • Patrick
    • Support Monkey

    Hi there @Prinz

    I hope you're well today!

    Yup, things like that can often happen when using a new post-type for the first time. This is a long-standing permalink quirk in WordPress.

    To fix it, all you need to do is refresh the permalinks. To do so, go to Settings > Permalinks in your admin, and set them to anything other than what they are now and Save. Then set them back to what they were before and save again.

    You should then be able to view and preview your new post-types without finding your 404 page.

    Please let us know if this helps, and don't hesitate to post again if you need more help with this.

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Prinz

    Hope you are doing good today and I am sorry for delay here :slight_smile:

    It seems that Patrick might stuck with some complex thread. So I decided to jump in, to help you solve this problem :slight_smile:

    I logged in using support staff and fixed the 404 error on "about me" post type while preview. Here is what I did. From your subsite that is aboutme.bestofthebestonly.com > admin > CustomPress > about_me > Supports unchecked this option Post Formats - Add post formats.. Save changes and now preview is working fine to me (see screenshot).

    You can do above for your other custom post types having similar issue or let me know the name of post type and I will fix them for you :slight_smile:

    Take care and have a nice weekend:slight_smile:

    Cheers, Sajid

  • Klaus
    • The Crimson Coder

    Hello Sajid,

    thanks for jumping in and fixing the issue. Well it's a great gesture of you offering

    - You can do above for your other custom post types having similar issue or let me know the name of post type and I will fix them for you :slight_smile:

    BUT

    as we are going to have heaps of new Post Formats we won't bothering all the time as we will believe we should be able to uncheck - check this by our own. However right now we need a tiny little bit more information on this subject from you which is

    - where do we find this option Post Formats - Add post formats.. Save changes and now preview is working fine to me (see screenshot)?

    Please do us the favor and send us a screenshot which indicates this button.

    Looking forward hearing from you soon.
    Thank you.
    Prinz

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Prinz

    Hope you are doing good today :slight_smile:

    I am sorry I forgot to attach the screenshot. Here I am attaching the animation (.gif) to remove the post format support from custom post type where you are facing similar porblem.

    Take care and have nice day :slight_smile:

    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.