Previous page navigation not working

Having some difficulty trying to navigate to older entries on the blog roll. This was a problem a year ago and someone said that the pagenation was missing some code. Below is what my pagnation code currently looks like. I also reset permalinks and turned off all of my plugins. The problem came when I upgraded to the version before the latest one. Can anyone help figure out why this is happening?

Website is wellsaidcabot.com

<?php if (is_single()) { ?>

<div id=”post-navigator-single”>

<div class=”alignleft”><?php previous_post_link(‘« %link’:wink: ?></div>

<div class=”alignright”><?php next_post_link(‘%link »’:wink: ?></div>

</div>

<?php } else if (is_page()) { ?>

<div id=”post-navigator”>

<?php wp_link_pages(__( ‘Pages’, ‘business-feature’ ), ”, __( ‘number’, ‘business-feature’ )); ?>

</div>

<?php } else if (is_tag()) { ?>

<div id=”post-navigator”>

<div class=”alignleft”><?php previous_post_link(‘%link’, __(‘« Previous Entries’, ‘business-feature’ )) ?></div>

<div class=”alignright”><?php next_post_link(‘%link’, __(‘Next Entries »’, ‘business-feature’ )); ?> </div>

</div>

<?php } else if ((is_category()) || (is_archive())) { ?>

<div id=”post-navigator”>

<div class=”alignleft”><?php previous_post_link(‘%link’, __(‘« Previous Entries’, ‘business-feature’ )) ?></div>

<div class=”alignright”><?php next_post_link(‘%link’, __(‘Next Entries »’, ‘business-feature’ )); ?> </div>

</div>

<?php } else { ?>

<div id=”post-navigator”>

<div class=”alignleft”><?php next_posts_link(__(‘« Previous Entries’, ‘business-feature’ )) ?></div>

<div class=”alignright”><?php previous_posts_link(__(‘Next Entries »’, ‘business-feature’ )); ?> </div>

</div>

<?php } ?>