Privacy Options BP Conflict

Sitewide Privacy Options plugin is breaking my BuddyPress Groups widget on my client's site. When clicking on Newest, Active, etc. group links at the top of the widget, I get this error:

Warning: Cannot modify header information - headers already sent by (output started at /home/vangua16/public_html/wp-content/plugins/buddypress/bp-groups/bp-groups-widgets.php:153) in /home/vangua16/public_html/wp-content/plugins/sitewide-privacy-options/sitewide-privacy-options.php on line 496

Could someone please help me resolve this? Thanks!

Here is the link to see this error in action: dreamsfirst.net