Private Messaging – Only Half "Send New Message Window" Displayed

Hi,

I just installed Private Messaging and having some issues with the plugin on a MacBook with the latest versions of WordPress and BuddyPress installed.

When opening the Send New Message window, the window is not displayed correctly. Please see the attachment (screen shot). I disabled all extensions of Safari, tried it with Firefox and Google Chrome, but all same.

Did you tested the plugin on an Apple MacBook? Maybe is a Java problem.

Thanks for your feedback, and regards,

Romanzy

  • Predrag Dubajic
    • Support

    Hey @romanzy,

    Hope you’re doing well today :slight_smile:

    I have just tested this on my site and the popup window was showing normally, I have BuddyPress installed and tested on Safari and Chrome on Macbook.

    Have you tried switching to default WP theme to see if the issue is theme related?

    Do you have link to your site where I can test this to see if it’s some simple CSS issue?

    Best regards,

    Predrag

  • romanzy
    • WPMU DEV Initiate

    Thank you for the quick reply. I’m running the site locally with the KLEO theme on MAMP PRO, so I can’t give you a link. It’s running with the latest PHP version also. I only have the necessary plugins installed, and tried to disable a few of them, but to no avail. The problem remains with the default themes, so it’s not the KLEO causing the problems. Please find in attachment my system info. As you can see, there is nothing really special installed. I disabled several plugins such as Contact Form 7, Events Manager, etc., but nothing helped.

  • romanzy
    • WPMU DEV Initiate

    Hi Pedrag,

    I’ve put a site online, a new clean install with the latest KLEO buddypress theme and the necessary plugins for Kleo, as well as Private Messaging (not other plugins). The Send New Message window is still displayed half, at least on my Macbook and this with all popular browsers. You can test the install at http://www.domatico.com.

    EDIT: Please don’t leave your login credentials here.

    The server is very slow, so if you can’t login instantly, then please try again till the connection goes trough. I’m looking forward for your feedback.

    Thank you in advance.

    ### Begin System Info ###

    — Site Info

    Site URL: http://domatico.com

    Home URL: http://domatico.com

    Multisite: No

    — User Browser

    Platform: Apple

    Browser Name: Safari

    Browser Version: 8.0.5

    User Agent String: Mozilla/5.0 (Macintosh; Intel Ma

    c OS X 10_10_3) AppleWebKit/600.

    5.6 (KHTML, like Gecko) Version/

    8.0.5 Safari/600.5.6

    — WordPress Configuration

    Version: 4.1.1

    Permalink Structure: /%postname%/

    Active Theme: Kleo Child (child theme)

    Parent Theme: Kleo 2.4.1

    Show On Front: page

    Page On Front: Home Default (#816)

    Page For Posts: Blog (#24)

    Remote Post: wp_remote_post() works

    Table Prefix: Length: 9 Status: Acceptable

    WP_DEBUG: Disabled

    Memory Limit: 256M

    — WordPress Active Plugins

    bbPress: 2.5.5

    BuddyPress: 2.2.1

    BuddyPress Cover Photo: 1.0.5

    K Elements: 2.4

    Paid Memberships Pro: 1.8

    Paid Memberships Pro – bbPress Add On: 1.1.5

    PMPro Email Templates: .5.2

    Private Messaging: 1.0.1.1-Beta

    Revolution Slider: 4.6.5

    rtMedia for WordPress, BuddyPress and bbPress: 3.7.33

    Taxonomy Metadata: 0.4

    WooCommerce: 2.3.5

    WordPress Importer: 0.6.1

    WPBakery Visual Composer: 4.4.2

    WP Bouncer: 1.1

    WPMU DEV Dashboard: 3.5.2

    YITH WooCommerce Wishlist: 2.0.4

    — WordPress Inactive Plugins

    Akismet: 3.1

    Duplicator: 0.5.12

    — Webserver Configuration

    PHP Version: 5.6.4

    MySQL Version: 50011

    Webserver Info: Apache

    — PHP Configuration

    Safe Mode: No

    Memory Limit: 256M

    Upload Max Size: 64M

    Post Max Size: 64M

    Upload Max Filesize: 64M

    Time Limit: 259200

    Max Input Vars: 1000

    Display Errors: On (1)

    — PHP Extensions

    cURL: Supported

    fsockopen: Supported

    SOAP Client: Installed

    Suhosin: Not Installed

    — Session Configuration

    Session: Enabled

    Session Name: PHPSESSID

    Cookie Path: /

    Save Path: /tmp

    Use Cookies: On

    Use Only Cookies: On

    ### End System Info ###

  • Predrag Dubajic
    • Support

    Hi @romanzy,

    Sorry for the delay on this one.

    Can you please allow support access so I can have a closer look at this?

    You can download and install WPMU DEV Dashboard from here:

    https://premium.wpmudev.org/project/wpmu-dev-dashboard/

    And then follow instructions from this page to grant access.

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Also, please share a link to page where I can test Private Messaging.

    Best regards,

    Predrag

  • romanzy
    • WPMU DEV Initiate

    EDIT: Please don’t leave your login credentials here.

    PS: the server is very slow; it’s a basic Dreamhost server, and hope it doesn’t make you too much trouble; sorry for that; if too slow, then please use Duplicator to create an install on your server if this would not take too much effort and time.

  • Predrag Dubajic
    • Support

    Hey @romanzy,

    Please don’t leave your login details here because the forums are public, I have removed the info from the previous comments but you might want to change that and if you need some more help enable the support access by following instructions from my previous comment.

    It looks like it’s Kleo theme CSS causing this, we can try fixing it by adding this CSS code to override the Kleo styling for this element:

    .compose-form-container .modal-dialog {
    left: 0;
    }

    You can use plugin like this one for this additional CSS. That way you’re protected when you come to upgrade.

    Let me know if this worked.

    Best regards,

    Predrag

  • romanzy
    • WPMU DEV Initiate

    Dear Pedrag,

    Thank you very much for your support. I thought I was sending you private messages which others couldn’t read, and so I sent you the login credentials. I’ll be more careful from now.

    Once again THANK YOU for your effort.

  • Predrag Dubajic
    • Support

    Hey @romanzy,

    All threads are public so other users can find a solution if they experience similar issues, that’s why we have support access option in WPMU DEV Dashboard plugin, once you enable access from that plugin only the staff members can access your site and there is no need to share your details.

    I’m glad to help, let us know if you need some more help with this.

    I’m marking this thread as resolved but if you have any followup questions feel free to reopen it.

    Best regards,

    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.