Pro features are not active for Custom Sidebars Pro

I've just purchased Custom Sidebars Pro. I didn't want to pay $20/mo for updates, and figured the current version would be fine for now. So I cancelled the subscription. I made sure that I just bought Custom Sidebars Pro, instead of the "all in one" wpmu subscription.

It seems like the pro features are not active, however. The WPMU Dev plugin says that Custom Sidebars Pro is installed, with a green checkmark. And it tells me that my account should remain active for about a month.

Yet I can't use the pro features. I still get the box that tells me to upgrade:

http://radleygh.com/images/SnippingTool_2014-248-14-14-50-12.png

1) How do I unlock the pro features? I've followed the instructions. I don't understand what went wrong.

2) Will the pro features work after the subscription period ends? The checkout screen made it sound like they will (just no updates/support), otherwise I would not have purchased.

3) Do I have to keep the WMPU Dev plugin running, and do I have to stay logged in? This isn't my site. I don't want my name or access to my account there.

  • Michelle Shull

    Hi, Radley!

    1. Do you still have the free version installed? If so, go ahead and deactivate it, and that should bring your settings back.
    2. Yep, the plugin will still work, but you'll no longer get updates.
    3. Nope, you don't have to use our dashboard to use any of our plugins.

    If my answer to #1 doesn't solve the issue, let me know and we can take a closer look.

    Take care!

  • Radley

    Thank you for the assistance. I'm happy about the answers for #2 and #3.

    For #1, I deactivated the free version of the plugin. It still said it was installed, so I removed it from the plugin folder. The manual download button wouldn't work (no error in console, strange). And the auto install wasn't set up.

    I realized that some of these issues are probably related to having the (development) domain password-protected. I disabled that and set up automatic updates as per the instructions. Eventually got the pro version installed and the new features are working.

    It is a bit confusing that it says "Custom Sidebars PRO - Installed", when it's actually only the free version.

    Oh well, it's working now. Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.